64-bit java crashing in nightly 64-bit

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: u354703, Unassigned)

Tracking

({64bit, crash})

10 Branch
x86
Windows 7
64bit, crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20111028])

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:10.0a1) Gecko/20111015 Firefox/10.0a1
Build ID: 20111015123308

Steps to reproduce:

i just downloaded the nightly build and installed the 64-bit java update (6.0.270.7) and the browser crashes (closes itself) instantly whenever an applet is loading.

it is reproducibile:

update java on the 64-bit nightly
go to any web-page with a java applet (java.com)
(Reporter)

Updated

6 years ago
Keywords: 64bit, crash
You mean it's a regression in todays build and it worked in yesterdays build ?
Not repro on 2011-10-16.

Could you attach crash id?  To find crash id, see http://support.mozilla.com/en-US/kb/Firefox%20crashes.
(Reporter)

Comment 3

6 years ago
im not sure about the earlier build.. still reproducible on my 2011-10-16 download

crash id: https://crash-stats.mozilla.com/report/index/bp-d5ddcb2e-c4b5-4553-bd9b-5b6b22111016
(Reporter)

Comment 4

6 years ago
after going through the crash report i dont believe its the correct one.. unless its based on the information of my other version 6 installations.

Comment 5

6 years ago
Flash is appearing in the crash report. Can you disable it (tools->addons->plugins)? Then try to produce a crash again.
(In reply to malithyapa from comment #3)
> im not sure about the earlier build.. still reproducible on my 2011-10-16
> download
> 
> crash id:
> https://crash-stats.mozilla.com/report/index/bp-d5ddcb2e-c4b5-4553-bd9b-
> 5b6b22111016

This crash id is on 32-bit firefox.  Do you have crash id on 64-bit firefox?
(Reporter)

Comment 7

6 years ago
heres the crash report when i tried this just after installing the alpha

https://crash-stats.mozilla.com/report/index/bp-dd1855c5-a314-4f0a-babd-75c362111022

i just tried it after disabling flash.. and it has no effect.. i dont think the crash report is uploaded yet though.. 
am i the only one facing this problem? should i try reinstalling java?

Comment 8

6 years ago
Cannot reproduce this crash with the given steps on Windows 7. Tried with multiple java versions (6 update 26, 27 and 29) and upgraded from one version to the next and tried launching different applets but still could not reproduce the crash. I tried on the latest nightly as well and still couldn't reproduce the crash. Below are the links to the java updates I tried and to the applets I tried.

Java updates 
  - http://www.oldapps.com/java.php
Applets 
  - http://www.schubart.net/rc/
  - http://www.falstad.com/fourier/
  - Tried some applets from http://java.sun.com/applets/jdk/1.4/index.html
  - Tried some applets from http://www.falstad.com/mathphysics.html

Tried on:
Build identifier: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:10.0a1) Gecko/20111015 Firefox/10.0a1
Build identifier: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:10.0a1) Gecko/20111028 Firefox/10.0a1
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME

Updated

6 years ago
Whiteboard: [testday-20111028]
(Reporter)

Comment 9

6 years ago
i installed java update 29 and now it works! :) thanks
You need to log in before you can comment on or make changes to this bug.