If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

overlay insert behavior has changed

RESOLVED INVALID

Status

Fennec Graveyard
Extension Compatibility
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: Eric Coleman, Assigned: mbrubeck)

Tracking

Firefox 8
x86
Windows 7

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.23) Gecko/20110920 Firefox/3.6.23
Build ID: 20110920075126

Steps to reproduce:

When creating an overlay, the insertion point behavior has changed.  In Fennec 7, the behavior matches Firefox.  In Fennec 8 and up the nightly as of now, the behavior has changed.  All that's been done is following the rules for creating an extension as per both Firefox and Fennec, (at least up to 7).


Actual results:

Inserting an overly as a child of a element with no ID attribute ends up making the overlay a sibling instead.


Expected results:

Here is a more detailed account of behavior changes:

Consider some chrome that looks like the following:

<hbox id="myparent">
 <vbox>
    <box id="child1" />
    <box id="child2" />
  </vbox>
<hbox>

In Firefox, and in Fennec 7 and lower, in order to put an overly as a sibling of "child1" the following code would have worked:

<overlay>
<hbox id="myparent">
 <vbox>
    <box id="myextension" insertbefore="child1">
     <!-- my extension chrome... -->
    </box>
</vbox>
</hbox>
</overlay>

That's supposed to result in the following:
<hbox id="myparent">
 <vbox>
    <box id="myextension" />
    <box id="child1" />
    <box id="child2" />
  </vbox>
<hbox>

However, in Fennec 8 and the current nightly, the following gets generated instead:
<hbox id="myparent">
 <vbox>
    <box id="child1" />
    <box id="child2" />
  </vbox>
 <vbox>
    <box id="myextension" />
 </vbox>
<hbox>
(Assignee)

Comment 1

6 years ago
Nominating for tracking-firefox8 because this is a regression that affects add-on compatibility in for Fennec update 8.

Eric, do you have an example extension (either a real extension or a minimized test case) that demonstrates this behavior?  What particular element(s) are you adding children to?
Assignee: nobody → mbrubeck
tracking-fennec: --- → ?
status-firefox10: --- → affected
status-firefox7: --- → unaffected
status-firefox8: --- → affected
status-firefox9: --- → affected
tracking-firefox8: --- → ?
Summary: overly insert behavior has changed → overlay insert behavior has changed
(Reporter)

Comment 2

6 years ago
Oops! I made a big mistake in filing this bug report.  My apologies to all. :)

I'm not entirely sure how I was able to observe what I did in Fennec 7.  However, the behavior in Fennec 8 and the nightly is the current behavior in Fennec 7, so there is no regression.
(Reporter)

Comment 3

6 years ago
Can the status of this be marked as invalid?  Thanks!
(Assignee)

Comment 4

6 years ago
Feel free to open a new bug if you believe the Fennec behavior is incorrect.  A test case would be great.
Status: UNCONFIRMED → RESOLVED
tracking-fennec: ? → ---
Last Resolved: 6 years ago
status-firefox10: affected → ---
status-firefox7: unaffected → ---
status-firefox8: affected → ---
status-firefox9: affected → ---
tracking-firefox8: ? → ---
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.