The default bug view has changed. See this FAQ.

crash nsIFrame::GetConstFrameSelection

VERIFIED FIXED in mozilla10

Status

()

Core
Disability Access APIs
--
critical
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: MarcoZ, Assigned: surkov)

Tracking

({crash})

Trunk
mozilla10
x86_64
Windows 7
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
This bug was filed from the Socorro interface and is 
report bp-fecef6e1-ff04-42ce-a934-3db5d2111017 .
============================================================= 

Alexander, this awfully looks like a regression from the recent work you did in that particular code area, right?
(Reporter)

Updated

6 years ago
Component: Disability Access → Disability Access APIs
Product: Firefox → Core
QA Contact: disability.access → accessibility-apis
(Assignee)

Comment 1

6 years ago
it is, looks like a dupe of bug 694824
(Reporter)

Comment 2

6 years ago
OK, I just reproduced this crash just by opening a bug URL from within Chatzilla. I have ChatZilla running as a XULRunner application, and I opened actually this very bug from within a chat window. So opening any link from within Thunderbird with NVDA running should reproduce this bug.
My report:
bp-f58bfb44-cbe3-4d4a-b7fb-dadbf2111017

Updated

6 years ago
Assignee: nobody → surkov.alexander
(Assignee)

Comment 3

6 years ago
Created attachment 567434 [details] [diff] [review]
patch

in this case document root frame is not constructed yet, in general frame might be not available for unattached subtree but not yet destroyed
Attachment #567434 - Flags: review?(marco.zehe)
(Assignee)

Updated

6 years ago
Duplicate of this bug: 694824
(Reporter)

Comment 5

6 years ago
Comment on attachment 567434 [details] [diff] [review]
patch

r=me.
Attachment #567434 - Flags: review?(marco.zehe) → review+
(Assignee)

Comment 6

6 years ago
inbound: https://hg.mozilla.org/integration/mozilla-inbound/rev/99f4d8ebbc2d
https://hg.mozilla.org/mozilla-central/rev/99f4d8ebbc2d
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla10
(Reporter)

Comment 8

6 years ago
Verified fixed in Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111019 Firefox/10.0a1
(Reporter)

Updated

6 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.