Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 694967 - Scratchpad encoding on save
: Scratchpad encoding on save
Status: RESOLVED DUPLICATE of bug 702144
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: unspecified
: x86 Mac OS X
: P2 normal (vote)
: ---
Assigned To: Michael Ratcliffe [:miker] [:mratcliffe]
: (Unavailable until Nov 1) Brian Grinstead [:bgrins]
Depends on:
  Show dependency treegraph
Reported: 2011-10-17 06:33 PDT by Kevin Dangoor
Modified: 2011-12-20 13:12 PST (History)
4 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Description Kevin Dangoor 2011-10-17 06:33:57 PDT
From the comments on the Introducing Scratchpad blog post

Great, but when i save a file with utf-8 characters in it (greek)
it comes back with strange characters….
How can i save a file from scratchpad with utf-8 or other
encodings ?


Which encoding are we using by default? If it's not utf-8, it seems like saving as utf-8 would be a good step. Of course, not everyone uses utf-8 so it may make sense at some point to offer the ability to set the encoding.
Comment 1 Dave Camp (:dcamp) 2011-10-27 08:30:52 PDT
We're doing developer tool prioritization, filter on 'brontozaur'
to ignore the spam.
Comment 2 Michael Ratcliffe [:miker] [:mratcliffe] 2011-12-20 04:37:36 PST
This seems to be working now ... try with the following text:
Εδώ είναι μερικές ελληνικό κείμενο

Works fine when using either orion or textarea as the editor.

Maybe this is a windows only problem as utf-8 is not default on that OS.
Comment 3 Michael Ratcliffe [:miker] [:mratcliffe] 2011-12-20 05:05:48 PST
Nope, works fine on windows too.

Works for me.
Comment 4 Panos Astithas [:past] 2011-12-20 05:35:56 PST
Are you sure you are saving the file? The moment the file is saved it's contents are garbled for me on Nightly. Actually, this is the same as bug 702144, which has a patch in it. So, I think we should mark this one as duplicate, even though it was filed earlier.
Comment 5 Michael Ratcliffe [:miker] [:mratcliffe] 2011-12-20 13:12:19 PST
I see, so this happens for some user but not for others. Reading bug 702144 this is certainly a duplicate.

*** This bug has been marked as a duplicate of bug 702144 ***

Note You need to log in before you can comment on or make changes to this bug.