Last Comment Bug 695035 - [GTK/X11] middle clicking in scratchpad should paste the X primary selection
: [GTK/X11] middle clicking in scratchpad should paste the X primary selection
Status: RESOLVED FIXED
[sourceeditor][orion]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: All Linux
: P2 normal (vote)
: Firefox 11
Assigned To: Mihai Sucan [:msucan]
:
:
Mentors:
Depends on: 695032 702331
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-17 09:54 PDT by David Baron :dbaron: ⌚️UTC-7 (busy September 14-25)
Modified: 2011-12-15 04:56 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2011-10-17 09:54:10 PDT
On the Linux/X11 desktop (definitely in GNOME apps, and I think in KDE as well), selecting text should make that text the X primary selection ("PRIMARY"), such that middle clicking in an app taking text input will paste that text.

(This is because X has a longstanding copy/paste model that's somewhat more like the mental model of dragging and dropping text than the Windows/Mac copy/paste model, except using select and middle-click.  The GNOME and KDE desktops have added a more Windows/Mac-like model with Copy and Paste operations in *addition* to that traditional model, but many X users use the traditional model.)

This bug reports that scratchpad does not accept the middle click input in this model (in contrast to bug 695032 which reports it doesn't place text in the selection when text is selected).

Steps to reproduce:
 1. select some text in a browser window
 2. Tools -> Web Developer -> Scratchpad
 3. middle click in the text editor

Expected results:  The text that you selected in step 1 gets pasted

Actual results: nothing
Comment 1 Zack Weinberg (:zwol) 2011-10-17 10:07:02 PDT
Please see https://bugzilla.gnome.org/show_bug.cgi?id=333514 for a lengthy description (written by me) of how PRIMARY/middle-mouse is supposed to work.  Please note further that the discussion in that bug includes several people arguing that it should not be fixed.  Those people are wrong.
Comment 2 Mihai Sucan [:msucan] 2011-10-19 02:55:27 PDT
Thank you David for the bug report, and thank you Zack for your explanation of how things should work.
Comment 3 Mihai Sucan [:msucan] 2011-10-19 13:44:08 PDT
Bug reported upstream:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=361474
Comment 4 Mihai Sucan [:msucan] 2011-12-15 04:56:13 PST
This bug is now fixed upstream and the code has been integrated into Firefox, see bug 702331.

Note You need to log in before you can comment on or make changes to this bug.