Integrate an Apps newsletter form on MDN Apps page

RESOLVED INCOMPLETE

Status

developer.mozilla.org
Wiki pages
P1
normal
RESOLVED INCOMPLETE
7 years ago
6 years ago

People

(Reporter: Dan Horner, Assigned: groovecoder)

Tracking

unspecified

Details

(Whiteboard: u=user c=content p=1)

(Reporter)

Description

7 years ago
Hi Jay

As per our call I'd like to request implementation of a newsletter signup form on the new MDN Apps page.

Cc'ing James Long to chime in here so it can be tied up on the backend.

Thanks

Dan
This library is needed: https://github.com/mozilla/webifyme/blob/master/ff4/things/responsys.py

Just copy that py file and call it like this:

responsys.subscribe('APP_DEV', 'test@example.com')

Other options can be passed; view the source.

Comment 2

7 years ago
I need one of the devs to take this on and get it in for 1.4.  It's a specific content requirement for the new Apps page, so hopefully one of you have some cycles to get work on this.

Luke/Les/James:  Who wants it?
Priority: -- → P1
Target Milestone: --- → 1.4
I don't have MDN setup at all, and it's a pretty easy bug, so luke/les can you take it? Feel free to ping me on IRC about it too.

You'll have to build out the form, style it, and implement the form process loop.
Assignee: nobody → craigcook.bugz
I'll pick it up tomorrow AM. My local code is in heavy construction on auth stuff right now.
(In reply to Luke Crouch [:groovecoder] from comment #4)
> I'll pick it up tomorrow AM. My local code is in heavy construction on auth
> stuff right now.

I'll have the form built and styled tonight so you can take over to make it functional in the morning.
Great! One other note: you'll need to grab the API key from https://mana.mozilla.org/wiki/display/websites/Responsys+configuration and put it as the RESPONSYS settings var.

Comment 7

7 years ago
Commit pushed to https://github.com/mozilla/kuma

https://github.com/mozilla/kuma/commit/d9eac99124ae7d0c533cc850197e865a73c48d9b
Merge pull request #32 from craigcook/mdn

Bug 695113 - Apps newsletter signup form
Assignee: craigcook.bugz → lcrouch
Whiteboard: u=user c=content p=1
To see this on stage9, activate https://developer-stage9.mozilla.org/admin/waffle/switch/3/

The 'Apps' item should show up under 'Topics'

On the Apps landing page you'll see the newsletter subscription form. You might need to ask jlongster how to verify the form submits all the way thru to responsys.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Keywords: qawanted
Resolution: --- → FIXED
(Reporter)

Comment 11

7 years ago
Hi Jay - how long until we can get this into the MDN/apps staging page - we'll need to tweak the copy on the form.
Sorry, it's there. I turned it off with a database switch so we could let Raymond do QA on the switch. I'll turn it back on. If it goes back off again, hop in #mdn or email us or comment here and either Jay or Raymond or I (or any other MDN admin) can turn it back on.

https://developer-stage9.mozilla.org/en-US/apps
(Reporter)

Comment 13

7 years ago
Hi Luke. Please can we integrate this form on the main page within the sidebar instead (at the top, and on the right hand side of the page).

Please replace the Lorem Ipsum with the following placeholder text:

"Sign up to the Apps newsletter for early access to developer resources tools, news, tips and tricks. Initial 5000 signups will receive early access to the Developer Preview Release."

Havi - please can you provide final text to replace the placeholder text above?
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Question: is there a way to preview the entire main page (just getting up to speed here) -- and does the "Apps newsletter" have any name or are we launching w/a generic name till brand questions are resolved? tia.
PLACEHOLDER: Sign up for the Apps newsletter

Sign up for the Apps newsletter for early access to developer resources, tools, news, tips and tricks. Initial 5000 signups will receive early access to the Developer Preview Release.

(QUESTION: Are we REALLY gating this? What does the 5001st subscriber receive?)

REVISED (draft): Apps Developer Newsletter

Sign up now for the Apps Developer preview and <monthly/weekly/recurring> newsletter. First 5000 subscribers gain early access to resources, tools, and exclusive info. <b>Join us!</b>
havi: I changed the text to the revised draft. If there are any more changes let us know ASAP.

Raymond, to test the newsletter signup, use the form on stage9 and then contact jlongster so he can check responsys.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
Don't forget to ask IT to add the production key to the Responsys key too. Just fyi.
thanks James. we've got it on our push pad: https://etherpad.mozilla.org/b8JWN2DsWi
(Reporter)

Comment 24

7 years ago
Luke / Raymond - sincerest apologies for this; there seems to have been a version control problem here. The text needs to be updated one last time to read:

Sign up now for the monthly Apps Developer newsletter. First 5000 subscribers will gain early access to the Developer Preview Release of the upcoming apps market-place. <b>Join us!</b>

Please let me know if we can get this in in time. Thanks in advance.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
copy updated

raymond did you test the responsys step with jlongster?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Keywords: qawanted
Resolution: --- → FIXED
(In reply to Luke Crouch [:groovecoder] from comment #26)
> copy updated
> 
> raymond did you test the responsys step with jlongster?

I didn't check for him. Raymond, ping me IRC with the email you submitted and I'll make sure it exists.
(In reply to James Long (:jlongster) from comment #27)
> (In reply to Luke Crouch [:groovecoder] from comment #26)
> > copy updated
> > 
> > raymond did you test the responsys step with jlongster?
> 
> I didn't check for him. Raymond, ping me IRC with the email you submitted
> and I'll make sure it exists.

I submitted me@example.com 


qa-verified-trunk https://developer-stage9.mozilla.org/en-US/apps
Keywords: qawanted

Comment 29

7 years ago
I'm not seeing the data flow into Responsys.  me@example.com wasn't populated with the flag.  It has data but from other tests.  

APP_DEV_FLG should be Y
APP_DEV_DATE should be date of opt-in
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: FIXED → ---
I'm guessing that something's wrong with the RESPONSYS key setting? I just submitted a new user and it doesn't even show up, so it looks like it never gets to Responsys.
James, you know better than I. Is the key value at https://github.com/mozilla/kuma/blob/mdn/lib/responsys.py#L32 the right value for the test server?

That's the one stage9 is using.
Target Milestone: 1.4 → 1.5
(In reply to Luke Crouch [:groovecoder] from comment #32)
> James, you know better than I. Is the key value at
> https://github.com/mozilla/kuma/blob/mdn/lib/responsys.py#L32 the right
> value for the test server?
> 
> That's the one stage9 is using.

Oh, duh. That's is the test key which files data into the TEST_CONTACTS_LIST file. Winston, check there. You probably have to add the APP_DEV_FLG and APP_DEV_DATE fields into that test file.

We usually just post some @example.com emails into the live list -- Responsys deletes them when they bounce anyway. But it's probably good to get in the habit of using the test list again.
At least, I *think* that's the test key. We haven't use it for a while. It might have been deactivated too when we generated new keys. Winston, can you check out that key?

Comment 35

7 years ago
I checked and didn't see me@example.com with the flags on the test contacts list.
How often does responsys delete them? Should we try a real-time test? Is there some way Raymond and/or I could get Responsys access so we can test ourselves?
(In reply to Luke Crouch [:groovecoder] from comment #36)
> How often does responsys delete them? Should we try a real-time test? Is
> there some way Raymond and/or I could get Responsys access so we can test
> ourselves?

I think just when we send a newsletter and the email bounces. I'd recommend just trying the live key on the mana page and see if it gets posted to the live list.

I can email you the credentials to login to Responsys. It's a difficult interface though.
After testing with James we discovered the responsys stage key is broken. During tomorrow's push we'll verify the responsys production key on both stage and production settings_local.py files so we can test the newsletter subscription again this week before the live push on Nov 14.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → INCOMPLETE
Version: MDN → unspecified
Component: Website → Landing pages
Product: Mozilla Developer Network → Mozilla Developer Network
You need to log in before you can comment on or make changes to this bug.