Window geometry in XUL does not work

VERIFIED WORKSFORME

Status

()

Core
XUL
VERIFIED WORKSFORME
17 years ago
9 years ago

People

(Reporter: Colin Phillips, Assigned: Peter Trudelle)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.16 i686; en-US; 0.8) Gecko/20010216
BuildID:    Stable Mozilla 0.8

When I try to set the window geometry in a XUL window, the values are not used
as specified.
<window ... width="400" height="400" ...> ... </window>
This should create a window of 400 x 400, but the window opens at the exact same
dimensions that it last closed as.

Reproducible: Always
Steps to Reproduce:
1) create a XUL window using <window>
2) set the window dimension attributes width & height
3) run the XUL file

Actual Results:  window opens at the same width & height as it last closed as

Expected Results:  window should open as specified width & height
Do you have something like persist="width height" among the "..."?
(Reporter)

Comment 2

17 years ago
Nope, its just an extreemly simple example.
Can you tell us that example? Works for me on Win NT.
(Reporter)

Comment 4

17 years ago
Weird, I got it to work properly now under Linux.  I think it was a problem with
the way i was calling it on the command line (the chrome url was just acting
funny).  Works for me now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
verified.
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.