Last Comment Bug 695322 - browser_privatebrowsing_searchbar.js is broken when run on its own, and doesn't fully clean up after itself
: browser_privatebrowsing_searchbar.js is broken when run on its own, and doesn...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Private Browsing (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 10
Assigned To: :Gavin Sharp [email: gavin@gavinsharp.com]
:
: :Ehsan Akhgari
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-18 07:27 PDT by :Gavin Sharp [email: gavin@gavinsharp.com]
Modified: 2011-10-21 02:13 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (2.37 KB, patch)
2011-10-18 07:30 PDT, :Gavin Sharp [email: gavin@gavinsharp.com]
ehsan: review+
Details | Diff | Splinter Review

Description :Gavin Sharp [email: gavin@gavinsharp.com] 2011-10-18 07:27:19 PDT
Two issues I discovered while debugging test failures in bug 692130:

1) this test leaves text in the search bar after it is run
2) this test fails when run individually

1) is easy to fix. 2) seems to be caused by assuming that the search bar already has an undo history, which isn't necessarily true given what the test does.
Comment 1 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-10-18 07:30:09 PDT
Created attachment 567741 [details] [diff] [review]
patch
Comment 2 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-10-20 08:50:18 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/5404bcfc627f
Comment 3 Marco Bonardo [::mak] 2011-10-21 02:13:04 PDT
https://hg.mozilla.org/mozilla-central/rev/5404bcfc627f

Note You need to log in before you can comment on or make changes to this bug.