Last Comment Bug 695433 - Inspect element re-opens when you switch away from tab
: Inspect element re-opens when you switch away from tab
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: 9 Branch
: x86 Linux
: -- normal (vote)
: Firefox 10
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-18 12:04 PDT by Ian Bicking (:ianb)
Modified: 2011-12-05 18:51 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Ian Bicking (:ianb) 2011-10-18 12:04:14 PDT
To reproduce:

* Inspect an element
* Close the inspector (with the "X")
* Go to a new tab (or an existing tab)
* Return to the original tab

Now the inspector will be open again, as though it was never closed.  Going to a new page stops this behavior.
Comment 1 Rob Campbell [:rc] (:robcee) 2011-10-18 12:52:57 PDT
You're claiming this is in 9 branch, is that accurate? (Beta?)

It was fixed in bug 690361 which is targeted at fx 10. Since this is preffed off for 9, I don't think we'll be able to land it on branch. :(
Comment 2 Ian Bicking (:ianb) 2011-10-18 12:54:47 PDT
I encountered it on 9.0a2 (2011-10-17) (Aurora)
Comment 3 Kevin Dangoor 2011-12-05 18:51:27 PST
I just tried this in Nightly and Aurora and this appears to have been fixed sometime in the last two months. Setting target for Firefox 10, since Aurora seems good.

Note You need to log in before you can comment on or make changes to this bug.