dropping into plaintexteditor should have can't drop cursor sometimes

REOPENED
Unassigned

Status

()

Core
Editor
REOPENED
17 years ago
8 years ago

People

(Reporter: sujay, Unassigned)

Tracking

({helpwanted})

Trunk
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
using 2/19 build of netscape

1) launch netscape
2) launch composer
3) Debug | plaintexteditor
4) insert an object into composer(image, h. line, link, target)
5) drag that object and drop into plaintexteditor

I know plaintext editor doesn't support these objects. So we
should be showing that drop as an illegal drag drop by changing
the cursor to reflect that..Currrently the cursor feedback looks
like a legal drop..

all platforms.

Comment 1

17 years ago
assigning to sfraser
Assignee: beppe → sfraser

Comment 2

17 years ago
giving to brade
Assignee: sfraser → brade
Priority: -- → P3
Target Milestone: --- → mozilla0.9

Comment 3

17 years ago
I have a partial fix for this bug...
Status: NEW → ASSIGNED

Comment 4

17 years ago
Created attachment 27172 [details] [diff] [review]
partial fix; check length of data before adding flavor
[Checkin: Comment 7]

Comment 5

17 years ago
pink:  please review
Simon:  please super-review
looks good, r=pink

Comment 7

17 years ago
I checked in this fix a few days ago
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

17 years ago
reopening...

two problem here:

1) the cursor doesn't reflect an illegal drop
2) the object doesn't get dropped in..

I wasn't sure if we decided to allow drag + drop of objects into
plaintext editor so I'm posting both issues...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 9

17 years ago
so, if nothing appears when dropped, then we should get the other cursor and not 
let people drop stuff.

For some reason, I'm seeing the "drop" being enabled because there is unicode 
flavor on clipboard (this is by dragging an hrule from composer to plaintext 
editor).  The unicode flavor shouldn't be present if there isn't any text.  It 
appears that it is being added without any content.  :-(
Status: REOPENED → ASSIGNED
Summary: can't drop objects into plaintexteditor → dropping into plaintexteditor should have can't drop cursor sometimes
Target Milestone: mozilla0.9 → mozilla1.0

Comment 10

17 years ago
spam composer change
Component: Editor: Core → Editor: Composer

Comment 11

16 years ago
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla1.0 → mozilla1.0.1

Updated

16 years ago
Keywords: helpwanted
Target Milestone: mozilla1.0.1 → Future
Product: Browser → Seamonkey
Attachment #27172 - Attachment description: partial fix; check length of data before adding flavor → partial fix; check length of data before adding flavor [Checkin: Comment 7]
Kathleen,
Are you still working on this ?
Priority: P3 → --
QA Contact: sujay → composer
Target Milestone: Future → ---

Comment 13

8 years ago
Doesn't look like this is still a helpful bug in its current state, moving to INCOMPLETE for the moment.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago8 years ago
Resolution: --- → INCOMPLETE

Comment 14

8 years ago
Incomplete?  What part of the steps are not understood?
I'm guessing this affects Mail Compose (plain text).
I would think a better question is: Can this bug be reproduced in TBird?

Comment 15

8 years ago
(In reply to comment #14)
> Incomplete?  What part of the steps are not understood?
> I'm guessing this affects Mail Compose (plain text).
> I would think a better question is: Can this bug be reproduced in TBird?

Kathleen, this had been without a comment for more than 6 years, then you didn't reply to a question for almost two years, so I don't see that something can be badly broken here.

That said, IMHO, Thunderbird is completely irrelevant as long as the bug is in the SeaMonkey product, the question would be if it can be reproduced in SeaMonkey 2.x, actually. And even then, I doubt this is either a SeaMonkey or a Thunderbird bug, if it still exists, it's probably a core editor thing.

Still, with over 8 years of no real activity, I'd call the bug bogus unless someone comes up and takes responsibility for it.

Comment 16

8 years ago
I believe my response to comment 12 was to add "helpwanted"

Sorry; I didn't notice what product this bug is assigned to.

Yes, I agree the bug will be in the core editor (not specific to SeaMonkey or Thunderbird).

I still contend that the bug is not "bogus"; instead you might say that it is irrelevant or unimportant.  I suggest resolving as WONTFIX (unless it is known that the bug can no longer be reproduced).

Comment 17

8 years ago
I didn't say it's irrelevant or unimportant. If it still might be of value, I'm all for reopening and moving it to core/editor (whatever the exact name of the component there is), I just wanted to clean out the SeaMonkey realm from it, and stumbled over this as it was still marked ASSIGNED to you but didn't have any progress.

So, if you think it's still relevant, please REOPEN it and move it where it actually belongs nowadays - I'm all happy if action actually might happen and our software gets improved!

Comment 18

8 years ago
reopening; recategorizing; helpwanted still applies
Assignee: brade → nobody
Status: RESOLVED → REOPENED
Component: Composer → Editor
Product: SeaMonkey → Core
QA Contact: composer → editor
Resolution: INCOMPLETE → ---
You need to log in before you can comment on or make changes to this bug.