Closed Bug 695504 Opened 8 years ago Closed 8 years ago

"This page requires a plugin that can only run in 32-bit mode" won't shut up

Categories

(Firefox :: General, defect)

10 Branch
x86
macOS
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: theosib, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:10.0a1) Gecko/20111017 Firefox/10.0a1
Build ID: 20111017031010

Steps to reproduce:

I am using a local network appliance that has a web interface.  The web interface uses iframes in order to display some dynamic info.  One of those iframes is requesting a plugin that can only be run in 32-bit mode.  


Actual results:

I dismiss the warning, because I don't care about it.  And then it comes back.  So i dismiss it, and then it comes back.  It's really annoying.  It's reappearing because the iframe is being reloaded.


Expected results:

The dismissal should be for the window, not any iframes inside it.  Once I've told it to go away, it should stay gone away unless I refresh the parent document.  The outer HTML is not changing, just an iframe inside it.

Alternatively, there should be a way to indicate that I don't want to see that warning again, ever.
BTW, the main reason it's so annoying is that it keeps shifting my document up and down.  Since my document keeps moving, I can't click on things right.  So, this is a compound bug:  Never move the document out from under the user's mouse for a stupid warning.
Can you please provide an example in order for me to test this?
Thanks
Not anymore.  Something has changed in a recent version of Firefox that has caused the plugin to start working, without giving me this warning.  In any case, I'm sure there are lots of plugins that cause this, and the main thing that needs to be fixed is to not shift the page down when the warning appears.
Considering comment3, can you please close this bug?
Thanks
I'll reopen if it recurs in the future.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.