need support for 3 letter language code

VERIFIED DUPLICATE of bug 22310

Status

()

VERIFIED DUPLICATE of bug 22310
18 years ago
18 years ago

People

(Reporter: bstell, Assigned: bstell)

Tracking

({intl})

Trunk
Future
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Assignee)

Description

18 years ago
From a separate email from erik@netscape.com:

http://cal-parks.ca.gov/ has this tag: <HTML LANG="ENG">

This is using a 3-letter language code. There is a new RFC on this:

  http://www.ietf.org/rfc/rfc3066.txt?number=3066

It points to the language code authority:

  http://lcweb.loc.gov/standards/iso639-2/

Here we find that "eng" is indeed a valid code. The RFC says that the codes are
case-insensitive, so "ENG" is valid too. However, we do not support the
3-letter codes yet:

  http://lxr.mozilla.org/seamonkey/source/intl/locale/src/langGroups.properties

So, we need to add the 3-letter codes to that table.

Comment 1

18 years ago
Changed QA contact to andreasb@netscape.com.
QA Contact: teruko → andreasb

Comment 2

18 years ago
mark it as future
Target Milestone: --- → Future

Updated

18 years ago
Keywords: intl

Comment 3

18 years ago

*** This bug has been marked as a duplicate of 22310 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
Verified as dupe. Please reopen in case someone disagrees.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.