searched add-ons are not listed in search results in FF3.6.23

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
7 years ago
3 years ago

People

(Reporter: pratibha, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

7 years ago
Tested with FF 3.6.23 on Windows platform:

Steps:
=========
1. Load https://addons-dev.allizom.org/en-US/firefox/
2. Enter "Firebug" in search field and click on go button
Note: Search suggestion shows "Firebug" add-on
3. Check "Firebug" is listed in search results : 
URL: https://addons-dev.allizom.org/en-US/firefox/search/?q=firebug&cat=all&appver=3.6.23&platform=windows


Result: Search results do not list "Firebug"

Note: Testing with FF 7.0.1, Nightly, Aurora this issue is not reproducible

screencast: http://tinyurl.com/5umatkr
Search Suggestions search add-ons by *name* only. Version compatibility is ignored by design. Since Firebug is not available for your application version (3.6.23), it doesn't appear in the Search Results. If you do remove the appver filter, Firebug is listed - as it should be. In summary, Search Suggestions are not intended to mirror Search Results.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX

Comment 2

7 years ago
This is a valid issue. If you load the details page for firebug in FF 3.6, you'd see that we list an older version (1.7.3) which supports FF 3.6. 
 
See bug 611534 for more details.

For a person on 3.6, it would be confusing to not be able to find an add-on which clearly supports the browser version. I'm fine with wontfixing it if we don't care about users on 3.6.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Target Milestone: --- → 6.2.8
https://addons-dev.allizom.org/en-US/firefox/addon/firebug/?src=search#detail-relnotes
According to Firebug's "Version Information" the current version "Works with Firefox 5.0 - 7.*"

As expected, Firebug shows up in the results for only FF 5.0 - 7.0:
https://addons-dev.allizom.org/en-US/firefox/search/?q=firebug&appver=5.0
https://addons-dev.allizom.org/en-US/firefox/search/?q=firebug&appver=6.0
https://addons-dev.allizom.org/en-US/firefox/search/?q=firebug&appver=7.0

Krupa, are you suggesting that search results should include add-ons that were once compatible with older application versions? I know this is somewhat discussed in bug 611534, but I don't think we want to search through all previous versions of every add-on - that seems to be more misleading. I may be missing something here. Let me know.
Target Milestone: 6.2.8 → ---
(Reporter)

Comment 4

7 years ago
Noticed an issue with install button also as follows in FF 3.6.23:

Steps:
=======
1. Load https://addons-dev.allizom.org/en-US/firefox/addon/yoono-twitter-facebook-linkedi/
2. Often used with: mouse hover on "LinkSidebar" add-on

Result: message displayed "Not available for Firefox 3.6.23" 
Note: but in details page an older version is listed to install

Also: 
- Compare
https://addons-dev.allizom.org/en-US/firefox/search/?q=LinkSidebar&cat=all&appver=3.6.23&platform=windows
to
https://addons-dev.allizom.org/en-US/firefox/search/?q=LinkSidebar&cat=al&platform=windows

Result: Shows the add-on with install button (older version file supported for 3.6.23).In same FF version,removing appver shows the add-on
The search results pages you linked to look fine to me; they show the expected results.

On the details page, however, if you look at the "Version Information" (https://addons-dev.allizom.org/en-US/firefox/addon/linksidebar/?src=search#detail-relnotes), it says "Works with Firefox 4.0 - 7.*."

It's not clear to me why the button is installable from the details page (using 3.6.23). But that is a different issue, one that is not related to search. I seem to recall there being a bug for this same issue. If there's not already a bug for it, please file one. Thanks :)
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
Resolution: FIXED → WONTFIX
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.