appver/platform filters are removed while searching in search results page

VERIFIED FIXED in 6.2.9

Status

addons.mozilla.org Graveyard
Search
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: Pratibha, Assigned: cvan)

Tracking

unspecified
6.2.9

Details

(URL)

(Reporter)

Description

7 years ago
Steps:
========
1. Load https://addons-dev.allizom.org/en-US/firefox/
2. Input "text" and click on Go button
3. Search results page is displayed at: https://addons-dev.allizom.org/en-US/firefox/search/?q=text&cat=all&appver=3.6.23&platform=windows
Note: appver/platform is picked up
4. In search results page do a search again ie click on Go button

Result: appver/platform parameters are gone now

resulting search page: https://addons-dev.allizom.org/en-US/firefox/search/?q=text&cat=all
(Assignee)

Comment 1

7 years ago
This is by design. If you are on the search results page, we don't want to prefill the appver and platform, since you can change that from the filters on the left. See bug 693360.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
That's pretty confusing. Can we update that info when facets are changed instead of removing them completely?
(Assignee)

Updated

7 years ago
Assignee: nobody → cwiemeersch
Status: RESOLVED → REOPENED
Hardware: x86 → All
Resolution: WONTFIX → ---
Target Milestone: --- → 6.2.8
(Assignee)

Comment 3

7 years ago
So all facets should be preserved upon new searches? Category, tags, and appver/platform selections? My fear is that if we autofill appver/platform on search results from the Search page, I'm going to always have to click the "Works With" section, "Any Firefox," and "All Systems" to filter the results to add-ons I want to see. I hate to do it, but perhaps we can provide a checkbox to disable autofilling the appver/platform? We're doing this detection transparently, and I'm sure it can be pretty frustrating for users who have no idea what's going on.
I don't think we need to preserve all facets; I think we should preserve appversion and platform because if the user had done a new search from another page, they would be there again. Preserving them shouldn't cause us to encounter the case you're concerned about: if I search for term A, reset my platform filters, and search for term B, we would preserve the platform filters and therefore the SERP for B would be unfiltered. If I didn't reset them, things would continue as normal.
Target Milestone: 6.2.8 → 6.2.9
(Assignee)

Comment 5

7 years ago
https://github.com/mozilla/zamboni/commit/56824c2
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

7 years ago
https://github.com/mozilla/zamboni/commit/4c72266

In addition to always showing the filtered appver and platform (even if it's not a facet), we now auto-detect the appver and platform - even on the search page. If the user chooses to filter by a different appver or platform, we now preserve those - even after another search with a different term (as long as the user doesn't leave the search results page). That's hot UX - IKR?

Comment 7

7 years ago
Verified as fixed in https://addons-dev.allizom.org/en-US/firefox/search/?q=text&cat=all&appver=3.6.23&platform=windows on Firefox 8 - Win 7
Postfix screenshot http://screencast.com/t/3GXBmce8Bane
Closing bug.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.