Closed Bug 695823 Opened 8 years ago Closed 7 years ago

The way that sessionstore closes tabs when recycling a window might be a source of performance issues

Categories

(Firefox :: Session Restore, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 816607

People

(Reporter: ehsan, Unassigned)

Details

(Keywords: perf)

So, Taras' laptop has a slow graphics driver which causes paints to be really slow.  Taras has noticed that when he has a lot of tabs, and he enters private browsing, Firefox performs really sluggish while sessionstore is closing his existing tabs for recylcing the window.

We're not quite sure what's causing the slowness, but we suspect that the way that sessionstore closes tabs is not really smart and could be improved.

This code seems to make sure that the active tab is closed last which helps (or should help) with us not repainting the content area needlessly, but FWIW it doesn't seem to work correctly for Taras:

http://mxr.mozilla.org/mozilla-central/source/browser/components/sessionstore/src/nsSessionStore.js#2612

The Close Other Tabs feature however is a lot faster.  This is the code responsible for that:

http://mxr.mozilla.org/mozilla-central/source/browser/base/content/tabbrowser.xml#1447

I'm filing this bug for more investigation on the sessionstore side.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 816607
You need to log in before you can comment on or make changes to this bug.