Last Comment Bug 695846 - move mozbase pieces into mozbase repo
: move mozbase pieces into mozbase repo
Status: RESOLVED FIXED
[mozbase]
:
Product: Testing
Classification: Components
Component: Mozmill (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Jeff Hammel
:
Mentors:
: 688630 (view as bug list)
Depends on: 696243
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-19 13:49 PDT by Jeff Hammel
Modified: 2011-10-24 09:47 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Jeff Hammel 2011-10-19 13:49:10 PDT
mozinfo, mozprocess, mozprofile, and mozrunner should be moved to https://github.com/mozilla/mozbase.

I'm not sure what we want to do with mutt.  I'm for leaving it here, for now, as it is mozmill specific, though the tests should actually live with the packages.  That is a whole other chunk of work though.

In addition to the actual move, preserving history, a few top-level resources should be fixed:

- https://github.com/mozautomation/mozmill/blob/master/carton-mozmill.py should checkout the relavent mozbase packages or something. the cartoned mozmill should be tested.  It should not hit net. All tests should pass.

- https://github.com/mozautomation/mozmill/blob/master/setup_development.py -- this should checkout/download the mozbase repo and set it up for development

- https://github.com/mozautomation/mozmill/blob/master/versionbump.py -- This should now only apply to jsbridge and mozmill.  Mozrunner version bumping should be done differently.

- https://github.com/mozautomation/mozmill/blob/master/docs.manifest -- this should be split off and the pointers to non-mozmill-repo documentation should live in the mozbase repo
Comment 1 cmtalbert 2011-10-19 14:00:52 PDT
Looks good to me.
Comment 2 Jeff Hammel 2011-10-19 15:40:36 PDT
*** Bug 688630 has been marked as a duplicate of this bug. ***
Comment 3 Andrew Halberstadt [:ahal] 2011-10-20 10:45:40 PDT
The move has finished, https://github.com/mozilla/mozbase

mozmill master: https://github.com/mozautomation/mozmill/commit/e56a769e4fed978a060d971bfee68756a1459193

I'll leave the bug open until the scripts get updated.
Comment 4 Jeff Hammel 2011-10-24 09:47:44 PDT
I think we can call this done. Please file follow up issues separately.

Note You need to log in before you can comment on or make changes to this bug.