Last Comment Bug 695859 - Don't progressively display images during decode if we have all of the data
: Don't progressively display images during decode if we have all of the data
Status: RESOLVED FIXED
[qa-]
:
Product: Core
Classification: Components
Component: ImageLib (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla12
Assigned To: Jeff Muizelaar [:jrmuizel]
:
Mentors:
Depends on:
Blocks: 698298
  Show dependency treegraph
 
Reported: 2011-10-19 14:13 PDT by Jeff Muizelaar [:jrmuizel]
Modified: 2012-03-29 20:43 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Do it (990 bytes, patch)
2011-10-19 15:11 PDT, Jeff Muizelaar [:jrmuizel]
bobbyholley: review+
Details | Diff | Splinter Review

Description Jeff Muizelaar [:jrmuizel] 2011-10-19 14:13:52 PDT
This fixes the problem shown in bug 626613. When we have all of the data, painting during decode just keeps us from finishing the decode sooner.
Comment 1 Jeff Muizelaar [:jrmuizel] 2011-10-19 15:11:29 PDT
Created attachment 568224 [details] [diff] [review]
Do it
Comment 2 Bobby Holley (:bholley) (busy with Stylo) 2011-10-19 17:03:05 PDT
Comment on attachment 568224 [details] [diff] [review]
Do it

This could turn out to be quite a significant behavioral change. It seems like a good idea in all the cases that come to mind, but I'm sure there are ones I haven't thought of.

Please test drive it a bit, and keep an eye on mozillazine after it lands to see what the masses have to say.

r=bholley
Comment 3 Marco Bonardo [::mak] 2012-01-05 08:44:52 PST
https://hg.mozilla.org/mozilla-central/rev/df2cf9afad63
Comment 4 Jeff Muizelaar [:jrmuizel] 2012-01-05 11:32:21 PST
*** Bug 698298 has been marked as a duplicate of this bug. ***
Comment 5 Justin Dolske [:Dolske] 2012-01-06 02:24:35 PST
If this is safe, can we look at landing this on Aurora too?
Comment 6 Joe Drew (not getting mail) 2012-01-10 20:34:40 PST
I don't think we should fast-track this.
Comment 7 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-03-29 15:40:51 PDT
Is there something QA can do to verify this fix?
Comment 8 Jeff Muizelaar [:jrmuizel] 2012-03-29 20:16:32 PDT
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #7)
> Is there something QA can do to verify this fix?

Not really, no.

Note You need to log in before you can comment on or make changes to this bug.