Last Comment Bug 695947 - [Linux PGO] Intermittent test_webgl_conformance_test_suite.html | Test failed, "successfullyParsed should be true. Threw exception ReferenceError: successfullyParsed is not defined" (URL: conformance/glsl/variables/*.html)
: [Linux PGO] Intermittent test_webgl_conformance_test_suite.html | Test failed...
Status: RESOLVED FIXED
: intermittent-failure
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: 438871
  Show dependency treegraph
 
Reported: 2011-10-19 19:46 PDT by Phil Ringnalda (:philor)
Modified: 2012-11-25 19:31 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
trigger GC frequently on linux i686 (1.37 KB, patch)
2011-10-21 13:02 PDT, Benoit Jacob [:bjacob] (mostly away)
no flags Details | Diff | Review

Description Phil Ringnalda (:philor) 2011-10-19 19:46:48 PDT
https://tbpl.mozilla.org/php/getParsedLog.php?id=6943195&tree=Mozilla-Inbound
Rev3 Fedora 12 mozilla-inbound pgo test mochitests-1/5 on 2011-10-19 19:09:48 PDT for push 2d649d1cc360

WebGL mochitest: starting page conformance/glsl/variables/gl-fragcoord.html
ResizeOffscreenFBO failed with AA, retrying without...
ResizeOffscreenFBO failed with AA, retrying without...
45996 ERROR TEST-UNEXPECTED-FAIL | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | Test failed, "successfullyParsed should be true. Threw exception ReferenceError: successfullyParsed is not defined" (URL: conformance/glsl/variables/gl-fragcoord.html)
WebGL test error: test page failure: conformance/glsl/variables/gl-fragcoord.html
WebGL mochitest: starting page conformance/glsl/variables/gl-frontfacing.html
ResizeOffscreenFBO failed with AA, retrying without...
ResizeOffscreenFBO failed with AA, retrying without...
45997 ERROR TEST-UNEXPECTED-FAIL | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | Test failed, "successfullyParsed should be true. Threw exception ReferenceError: successfullyParsed is not defined" (URL: conformance/glsl/variables/gl-frontfacing.html)
WebGL test error: test page failure: conformance/glsl/variables/gl-frontfacing.html
Comment 1 Treeherder Robot 2011-10-20 02:27:28 PDT
mak77%bonardo.net
https://tbpl.mozilla.org/php/getParsedLog.php?id=6945701&tree=Mozilla-Inbound
Rev3 Fedora 12x64 mozilla-inbound pgo test mochitests-1/5 on 2011-10-20 00:48:58

45998 ERROR TEST-UNEXPECTED-FAIL | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | Test failed, "successfullyParsed should be true. Threw exception ReferenceError: successfullyParsed is not defined" (URL: conformance/misc/invalid-passed-params.html)
45999 ERROR TEST-UNEXPECTED-FAIL | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | Test failed, "Unable to fetch WebGL rendering context for Canvas" (URL: conformance/misc/is-object.html)
46000 ERROR TEST-UNEXPECTED-FAIL | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | Test failed, "successfullyParsed should be true. Threw exception ReferenceError: successfullyParsed is not defined" (URL: conformance/misc/is-object.html)
46001 ERROR TEST-UNEXPECTED-FAIL | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | Test failed, "Unable to fetch WebGL rendering context for Canvas" (URL: conformance/misc/null-object-behaviour.html)
46002 ERROR TEST-UNEXPECTED-FAIL | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | Test failed, "successfullyParsed should be true. Threw exception ReferenceError: successfullyParsed is not defined" (URL: conformance/misc/null-object-behaviour.html)
Comment 2 Treeherder Robot 2011-10-20 07:42:08 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=6948958&tree=Mozilla-Inbound
Rev3 Fedora 12 mozilla-inbound pgo test mochitests-1/5 on 2011-10-20 04:58:08

45987 ERROR TEST-UNEXPECTED-FAIL | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | Test failed, "successfullyParsed should be true. Threw exception ReferenceError: successfullyParsed is not defined" (URL: conformance/glsl/variables/gl-fragcoord.html)
Comment 3 Treeherder Robot 2011-10-21 02:28:26 PDT
mak77%bonardo.net
https://tbpl.mozilla.org/php/getParsedLog.php?id=6965144&tree=Firefox
Rev3 Fedora 12 mozilla-central pgo test mochitests-1/5 on 2011-10-21 00:50:52

46016 ERROR TEST-UNEXPECTED-FAIL | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | Test failed, "successfullyParsed should be true. Threw exception ReferenceError: successfullyParsed is not defined" (URL: conformance/glsl/variables/gl-fragcoord.html)
46017 ERROR TEST-UNEXPECTED-FAIL | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | Test failed, "successfullyParsed should be true. Threw exception ReferenceError: successfullyParsed is not defined" (URL: conformance/glsl/variables/gl-frontfacing.html)
46018 ERROR TEST-UNEXPECTED-FAIL | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | Test failed, "successfullyParsed should be true. Threw exception ReferenceError: successfullyParsed is not defined" (URL: conformance/glsl/variables/gl-pointcoord.html)
Comment 4 Benoit Jacob [:bjacob] (mostly away) 2011-10-21 13:02:49 PDT
Created attachment 568747 [details] [diff] [review]
trigger GC frequently on linux i686

Jeff had the idea that this could be caused by the slaves running out of (video) memory, which fits well with the fact that the JS engine tends to keep unreferenced WebGL contexts around very long before GCing (see bug 617453). This patch triggers a GC before starting every webgl test page.

on try:
https://tbpl.mozilla.org/?tree=Try&rev=a3d9424c6296

retrigger a dozen times to check if it fixes the problem.
Comment 5 Benoit Jacob [:bjacob] (mostly away) 2011-10-21 13:26:27 PDT
didn't have PGO enabled. new try: https://tbpl.mozilla.org/?tree=Try&rev=789cf49fdc63
Comment 6 Treeherder Robot 2011-10-21 20:31:52 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=6979443&tree=Mozilla-Inbound
Rev3 Fedora 12x64 mozilla-inbound pgo test mochitests-1/5 on 2011-10-21 19:48:31

45998 ERROR TEST-UNEXPECTED-FAIL | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | Test failed, "successfullyParsed should be true. Threw exception ReferenceError: successfullyParsed is not defined" (URL: conformance/glsl/variables/gl-pointcoord.html)
45999 ERROR TEST-UNEXPECTED-FAIL | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | Test failed, "Unable to fetch WebGL rendering context for Canvas" (URL: conformance/limits/gl-min-attribs.html)
46000 ERROR TEST-UNEXPECTED-FAIL | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | Test failed, "successfullyParsed should be true. Threw exception ReferenceError: successfullyParsed is not defined" (URL: conformance/limits/gl-min-attribs.html)
46001 ERROR TEST-UNEXPECTED-FAIL | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | Test failed, "Unable to fetch WebGL rendering context for Canvas" (URL: conformance/limits/gl-max-texture-dimensions.html)
46002 ERROR TEST-UNEXPECTED-FAIL | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | Test failed, "successfullyParsed should be true. Threw exception ReferenceError: successfullyParsed is not defined" (URL: conformance/limits/gl-max-texture-dimensions.html)
46003 ERROR TEST-UNEXPECTED-FAIL | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | Test failed, "Unable to fetch WebGL rendering context for Canvas" (URL: conformance/limits/gl-min-textures.html)
46004 ERROR TEST-UNEXPECTED-FAIL | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | Test failed, "successfullyParsed should be true. Threw exception ReferenceError: successfullyParsed is not defined" (URL: conformance/limits/gl-min-textures.html)
46005 ERROR TEST-UNEXPECTED-FAIL | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | Test failed, "Unable to fetch WebGL rendering context for Canvas" (URL: conformance/limits/gl-min-uniforms.html)
46006 ERROR TEST-UNEXPECTED-FAIL | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | Test failed, "successfullyParsed should be true. Threw exception ReferenceError: successfullyParsed is not defined" (URL: conformance/limits/gl-min-uniforms.html)
Comment 7 Benoit Jacob [:bjacob] (mostly away) 2011-10-21 21:41:29 PDT
(In reply to Benoit Jacob [:bjacob] from comment #5)
> didn't have PGO enabled. new try:
> https://tbpl.mozilla.org/?tree=Try&rev=789cf49fdc63

All green after 12 retriggers. Will land tomorrow.
Comment 8 Benoit Jacob [:bjacob] (mostly away) 2011-10-21 21:42:09 PDT
(In reply to TinderboxPushlog Robot from comment #6)
> philor
> https://tbpl.mozilla.org/php/getParsedLog.php?id=6979443&tree=Mozilla-Inbound
> Rev3 Fedora 12x64 mozilla-inbound pgo test mochitests-1/5 on 2011-10-21

Very interesting to see that it also happens on 64bit slaves. Will update patch accordingly.
Comment 9 Benoit Jacob [:bjacob] (mostly away) 2011-10-22 10:49:50 PDT
http://hg.mozilla.org/mozilla-central/rev/a0784cecf9bd

Keeping this bug open until the next m-c -> m-i merge
Comment 10 Marco Bonardo [::mak] 2011-10-24 02:04:45 PDT
(In reply to Benoit Jacob [:bjacob] from comment #9)
> http://hg.mozilla.org/mozilla-central/rev/a0784cecf9bd
> 
> Keeping this bug open until the next m-c -> m-i merge

that's not needed and easy to miss, indeed it already happened. Landing on m-c should immediately mark bugs as fixed, they can always be reopened indeed.
Comment 11 Benoit Jacob [:bjacob] (mostly away) 2011-10-24 04:18:05 PDT
(In reply to Marco Bonardo [:mak] from comment #10)
> (In reply to Benoit Jacob [:bjacob] from comment #9)
> > http://hg.mozilla.org/mozilla-central/rev/a0784cecf9bd
> > 
> > Keeping this bug open until the next m-c -> m-i merge
> 
> that's not needed and easy to miss, indeed it already happened. Landing on
> m-c should immediately mark bugs as fixed, they can always be reopened
> indeed.

This is a special case: this bug and bug 696009 have been used to star very frequent intermittent oranges. Having them marked as fixed before oranges were completely gone on inbound could have confused people trying to star oranges there. I was not going to forget about it. Thanks for closing though.

Note You need to log in before you can comment on or make changes to this bug.