pushlog shouldn't depend on simplejson anymore, and use json if possible

RESOLVED DUPLICATE of bug 1074491

Status

Developer Services
Mercurial: hg.mozilla.org
RESOLVED DUPLICATE of bug 1074491
6 years ago
3 years ago

People

(Reporter: Pike, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Right now, you have to have simplejson to use pushlog, which is sad given that current python's can do without it perfectly with their own json support.
Created attachment 568352 [details] [diff] [review]
Patch to make simplejson dep optional

Can you check this? It seems to pass most of the tests for me, but I have some problems because my hg is too modern for the templates (bug 666870).
(Reporter)

Comment 2

6 years ago
Comment on attachment 568352 [details] [diff] [review]
Patch to make simplejson dep optional

My untested patch looks similar, I'd try builtin json before simplejson, though.

I'll do a real look later.
(Reporter)

Comment 3

6 years ago
The signoff view passes the from/to in the wrong order.
(Reporter)

Comment 4

6 years ago
(wrong bug)
(Assignee)

Updated

4 years ago
Product: mozilla.org → Release Engineering

Comment 5

4 years ago
Isn't this a duplicate of bug 800557?
(Assignee)

Updated

3 years ago
Product: Release Engineering → Developer Services

Updated

3 years ago
Whiteboard: [kanban:engops:https://kanbanize.com/ctrl_board/6/116]

Comment 6

3 years ago
This was done as part of bug 1074491.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1074491
(Assignee)

Updated

3 years ago
Whiteboard: [kanban:engops:https://kanbanize.com/ctrl_board/6/116]
You need to log in before you can comment on or make changes to this bug.