Last Comment Bug 696030 - nsGIOProtocolHandler.cpp:241:3: error: ‘MonitorAutoEnter’ is not a member of ‘mozilla’ when building with --enable-extensions=gio
: nsGIOProtocolHandler.cpp:241:3: error: ‘MonitorAutoEnter’ is not a member of ...
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Networking (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: mozilla12
Assigned To: Chris Coulson
:
:
Mentors:
: 684616 (view as bug list)
Depends on:
Blocks: 556214 713802
  Show dependency treegraph
 
Reported: 2011-10-20 04:33 PDT by Chris Coulson
Modified: 2012-01-05 08:31 PST (History)
4 users (show)
karlt: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Use ReentrantMonitor rather than Monitor in nsGIOProtocolHandler (2.95 KB, patch)
2011-10-20 04:39 PDT, Chris Coulson
no flags Details | Diff | Splinter Review
Use MonitorAutoEnter rather than MonitorAutoLock in nsGIOProtocolHandler (1.92 KB, patch)
2011-12-29 07:23 PST, Chris Coulson
karlt: review+
Details | Diff | Splinter Review

Description Chris Coulson 2011-10-20 04:33:14 PDT
When building with --enable-extensions=gio, I get this build failure:

c++ -o nsGIOProtocolHandler.o -c -I../../dist/stl_wrappers -I../../dist/system_wrappers -include /home/chr1s/src/firefox/mozilla-central/config/gcc_hidden.h -DOSTYPE=\"Linux3.0\" -DOSARCH=Linux -pthread -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include   -I/home/chr1s/src/firefox/mozilla-central/extensions/gio -I. -I../../dist/include -I../../dist/include/nsprpub  -I/home/chr1s/src/firefox/mozilla-central/obj-x86_64-unknown-linux-gnu/dist/include/nspr -I/home/chr1s/src/firefox/mozilla-central/obj-x86_64-unknown-linux-gnu/dist/include/nss      -fPIC  -fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -pedantic -Wno-long-long -g -fno-strict-aliasing -std=gnu++0x -pthread -ffunction-sections -fdata-sections -pipe  -DDEBUG -D_DEBUG -DTRACING -g -Os -freorder-blocks  -fno-omit-frame-pointer   -DMOZILLA_CLIENT -include ../../mozilla-config.h -MD -MF .deps/nsGIOProtocolHandler.pp /home/chr1s/src/firefox/mozilla-central/extensions/gio/nsGIOProtocolHandler.cpp
/home/chr1s/src/firefox/mozilla-central/extensions/gio/nsGIOProtocolHandler.cpp: In member function ‘void nsGIOInputStream::SetMountResult(MountOperationResult, gint)’:
/home/chr1s/src/firefox/mozilla-central/extensions/gio/nsGIOProtocolHandler.cpp:241:3: error: ‘MonitorAutoEnter’ is not a member of ‘mozilla’
/home/chr1s/src/firefox/mozilla-central/extensions/gio/nsGIOProtocolHandler.cpp:241:29: error: expected ‘;’ before ‘mon’
/home/chr1s/src/firefox/mozilla-central/extensions/gio/nsGIOProtocolHandler.cpp:244:3: error: ‘mon’ was not declared in this scope
/home/chr1s/src/firefox/mozilla-central/extensions/gio/nsGIOProtocolHandler.cpp: In member function ‘nsresult nsGIOInputStream::MountVolume()’:
/home/chr1s/src/firefox/mozilla-central/extensions/gio/nsGIOProtocolHandler.cpp:266:3: error: ‘MonitorAutoEnter’ is not a member of ‘mozilla’
/home/chr1s/src/firefox/mozilla-central/extensions/gio/nsGIOProtocolHandler.cpp:266:29: error: expected ‘;’ before ‘mon’
/home/chr1s/src/firefox/mozilla-central/extensions/gio/nsGIOProtocolHandler.cpp:269:5: error: ‘mon’ was not declared in this scope
make[6]: *** [nsGIOProtocolHandler.o] Error 1
Comment 1 Chris Coulson 2011-10-20 04:39:53 PDT
Created attachment 568355 [details] [diff] [review]
Use ReentrantMonitor rather than Monitor in nsGIOProtocolHandler
Comment 2 Karl Tomlinson (:karlt) 2011-11-02 20:28:55 PDT
This doesn't need to be a re-entrant monitor, so a better fix would be to change MonitorAutoEnter to MonitorAutoLock.
Comment 3 Wolfgang Rosenauer [:wolfiR] 2011-11-30 07:38:23 PST
*** Bug 684616 has been marked as a duplicate of this bug. ***
Comment 4 Chris Coulson 2011-12-29 07:23:25 PST
Created attachment 584745 [details] [diff] [review]
Use MonitorAutoEnter rather than MonitorAutoLock in nsGIOProtocolHandler
Comment 5 Karl Tomlinson (:karlt) 2011-12-29 18:47:07 PST
Comment on attachment 584745 [details] [diff] [review]
Use MonitorAutoEnter rather than MonitorAutoLock in nsGIOProtocolHandler

The checkin comment just needs touching up.
The method names are round the wrong way or something.
Comment 7 Marco Bonardo [::mak] 2012-01-05 08:31:07 PST
https://hg.mozilla.org/mozilla-central/rev/21c2b8c54c54

Note You need to log in before you can comment on or make changes to this bug.