Last Comment Bug 696093 - WebGL doesn't work after Bug 615976
: WebGL doesn't work after Bug 615976
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Jeff Gilbert [:jgilbert]
:
Mentors:
http://www.ibiblio.org/e-notes/webgl/...
Depends on:
Blocks: 615976
  Show dependency treegraph
 
Reported: 2011-10-20 08:28 PDT by ojab
Modified: 2011-10-20 20:42 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
glxinfo output (24.66 KB, text/plain)
2011-10-20 08:28 PDT, ojab
no flags Details
Fix ResizeOffscreen FBO not properly retrying without AA after failing with AA. (2.12 KB, patch)
2011-10-20 15:13 PDT, Jeff Gilbert [:jgilbert]
jacob.benoit.1: review+
Details | Diff | Review

Description ojab 2011-10-20 08:28:36 PDT
Created attachment 568400 [details]
glxinfo output

Can't get WebGL window and "ResizeOffscreenFBO failed with AA, retrying without..." after opening any WebGL demo after Bug 615976 fixed.
The same with webgl.force-enable=true.

MSAA _is_ available on my driver.
Comment 1 Jeff Gilbert [:jgilbert] 2011-10-20 15:12:21 PDT
Confirmed that ResizeOffscreenFBO does not properly retry after AA failure.

I'll take a look at your glxinfo to try to see why it failed in the first place, but it's a bug that it doesn't fallback to no-aa properly.
Comment 2 Jeff Gilbert [:jgilbert] 2011-10-20 15:13:28 PDT
Created attachment 568536 [details] [diff] [review]
Fix ResizeOffscreen FBO not properly retrying without AA after failing with AA.
Comment 3 Jeff Gilbert [:jgilbert] 2011-10-20 15:24:53 PDT
After going over your glxinfo, it looks like while your OpenGL implementation supports AA (that is, it has the right functions), and your card also likely supports AA (you'd be hard-pressed to find one which doesn't, these days), your current drivers do not support any level of MSAA.

The 'ms' column regards the level of multisampling supported for that config line. The 'ns' is the number of samples, and 'b' appears to be something having to do with the number of buffers (either required or available). Unfortunately, all of the config lines in your gfxinfo under 'ms' are '0', meaning that it is not possible to get hardware antialiasing with your current driver/card/system configuration.

You may check if there have been any driver updates, though, because that would by my guess as to what's not supporting multisampling.
Comment 4 Benoit Jacob [:bjacob] (mostly away) 2011-10-20 20:32:30 PDT
This user is already on a very recent development snapshot of Mesa and the radeon driver, so it could be that MSAA is not available at all in the radeon driver, which would suck.
Comment 5 Benoit Jacob [:bjacob] (mostly away) 2011-10-20 20:35:14 PDT
Comment on attachment 568536 [details] [diff] [review]
Fix ResizeOffscreen FBO not properly retrying without AA after failing with AA.

Review of attachment 568536 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for the quick patch. Landing right away on mozilla-central, skipping inbound, so that it will be in tomorrow's nightly at the same time as the AA patches.
Comment 6 Benoit Jacob [:bjacob] (mostly away) 2011-10-20 20:42:43 PDT
https://hg.mozilla.org/mozilla-central/rev/2afc252b4d39

Note You need to log in before you can comment on or make changes to this bug.