panic.com - Items are not shown correctly in shopping cart

RESOLVED INVALID

Status

Tech Evangelism
Desktop
RESOLVED INVALID
6 years ago
3 years ago

People

(Reporter: mihaelav, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
Mozilla/5.0 (Windows NT 6.1; rv:8.0) Gecko/20100101 Firefox/8.0

STR:
1. Go to panic.com/goods
2. Drag some items in shopping cart
3. Remove some items from shopping cart
4. Repeat steps 2 and 3 several times

Actual result:
After a while, items are not displayed in shopping cart even if they are still there and the prices are added to the total price amount.

Expected:
All items should be displayed correctly in the shopping cart.
I can reproduce the problem in Fx7 and Fx8.  I can also reproduce the problem in
Google Chrome so it seems the error is in the page itself.
Assignee: nobody → english-us
Component: General → English US
OS: Windows 7 → All
Product: Core → Tech Evangelism
QA Contact: general → english-us
Hardware: x86 → All
Summary: Items are not shown correctly in shopping cart → panic.com - Items are not shown correctly in shopping cart
Whiteboard: [8b4]
Version: 8 Branch → unspecified

Comment 2

6 years ago
Are there specific JS errors associated with the failure?

ccing Cabel; hopefully he'll know who needs to be made aware of this.

Comment 3

6 years ago
Somehow, I can't reproduce this — how many items are we talking about? — but I definitely wouldn't be surprised if it's our bug.

As asked above, any Javascript errors?

Comment 4

6 years ago
Using Firefox 9.0a2, the only thing i see in the console is:
Warning: Use of captureEvents() is deprecated. To upgrade your code, use the DOM 2 addEventListener() method. For more help http://developer.mozilla.org/en/docs/DOM:element.addEventListener
Source File: http://panic.com/goods/
Line: 0

This is logged every time I click (and start dragging) an item in the page, or in the basket.

Note: If I have 2 items in the basket, I can drag one out no problem. If I have 3 or more, I can't drag any item out of the basket (they bounce back).
(Reporter)

Comment 5

6 years ago
After thoroughly testing I was able to reproduce the issue on other browsers, as well e.g: IE, Chrome, Safari.
This seems to be a website issue, hence marking it as INVALID.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
It's invalid as a Firefox bug, but when a bug becomes a tech evang bug
it's about the informing / helping the site fix it.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Comment 7

3 years ago
"Panic Goods is Closed"
RIP.
Assignee: english-us → nobody
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago3 years ago
Component: English US → Desktop
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.