Last Comment Bug 6961 - When reply to a msg with JPN headers, Subject is displayed as raw MIME-encoded string
: When reply to a msg with JPN headers, Subject is displayed as raw MIME-encode...
Status: VERIFIED FIXED
:
Product: MailNews Core
Classification: Components
Component: Internationalization (show other bugs)
: Trunk
: x86 Windows NT
: P3 major (vote)
: M9
Assigned To: rhp (gone)
: Katsuhiko Momoi
Mentors:
: 8460 (view as bug list)
Depends on:
Blocks: 7228
  Show dependency treegraph
 
Reported: 1999-05-23 23:46 PDT by Katsuhiko Momoi
Modified: 2008-07-31 01:22 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Katsuhiko Momoi 1999-05-23 23:46:38 PDT
** Observed with 5/23/99 Win32 build **

1. Send yourself a msg from 4.6 in Japanese with the Subject and body in
   Japanese.

With 4.6, you can copy paste this string wit the Character Set set to
Japanese (Auto-Detect) on your browser. As long as the new Composer's
Character set is set to Japanese (Auto-Detect) and your global default
set to Japanese, this should work.

http://kaze:8000/ldapstring.txt

2. Receive this msg with 5.0 Messenger
3. Confirm that the message header is displaying correctly on the
   thread pane header.
4. Now engage the "reply" button.
5. Note that the quoted subject is in raw MIME-encoded format rather
   than showing as Japanese.

Reply/Quote in Japanese is part of the International requirements
for M6. This then has to be working for M6.

Naoki, if this is still true, please set the TFV to M6.
Comment 1 nhottanscp 1999-06-03 17:14:59 PDT
I think this is a widget problem, we need to switch to Ender.
I checked in the debugger that messenger is passing correct Unicode String (for
Japanese) to the widget (nsIDOMHTMLInputElement).
Comment 2 nhottanscp 1999-06-21 11:38:59 PDT
*** Bug 8460 has been marked as a duplicate of this bug. ***
Comment 3 rhp (gone) 1999-07-05 21:20:59 PDT
There seems to be a problem in general with UTF-8 encoding. Currently, sending
META tags to Ender doesn't let you edit the document. I've turned off UTF-8
output in quoting until we can get this fixed. Also, added akkana to the cc
list.

Shoot for M9 on this one.

- rhp
Comment 4 rhp (gone) 1999-07-26 19:50:59 PDT
I have a fix for this in my tree. Now that the Ender problem of reloading URL's
has been fixed, I can checkin in my fix when the tree opens.

This is a simple libmime change of stuff that I commented out (emitting META
tags).

- rhp
Comment 5 Katsuhiko Momoi 1999-07-30 17:31:59 PDT
** Checked with 7/30/99 Win32 build **

This is now fixed. Currently because we are not using
GFX widget in the subject field, we see dots instead of
Japanese characters, but when the GFX widget.mode=2 is set,
you actually see Japanese indicating that MIME headers are
getting decoded properly.

Rich, should the GFX widget thing be part of this bug?
If not, I'll go ahead and mark it verified.
Comment 6 rhp (gone) 1999-07-31 07:19:59 PDT
The GFX widget falls under Jean-Francios's area so I wouldn't mix the two.

- rhp
Comment 7 Katsuhiko Momoi 1999-08-01 21:58:59 PDT
Marking it verified as fixed based on the results of testing
with 7/3099 Win32 build.

Note You need to log in before you can comment on or make changes to this bug.