Closed Bug 696122 Opened 9 years ago Closed 9 years ago

L10n files (lightning-AB-CD.jar) missing in Lightning 1.0rc builds

Categories

(Calendar :: Build Config, defect)

Lightning 1.0
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ssitter, Assigned: standard8)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

The build from https://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/1.0rc2-candidates/build1/win32/ is missing all lightning-AB-CD.jar files and the corresponding entry in chrome.manifest.
Oh, that's strange. Looking.
Are you sure you got the right file? I just downloaded it and checked, and it had everything there.

The md5sum of the file was:

624213e594b5a26a0829c280d0bde5f0 *lightning.xpi
Yes. I have the same package with same hash. 

Look into the lightning.xpi\chrome\ folder. You'll find lightning-en-US.jar but all other lightning-AB-CD.jar files are missing. 

Look into lightning.xpi\chrome.manifest file. You'll find only the line "locale lightning en-US jar:chrome/lightning-en-US.jar!/locale/en-US/lightning/". It is missing for all other locales.

Problem doesn't exist in the older 1.0rc1-candidates builds.
Attached file Transcript of download/expansion (obsolete) —
Sorry, I just don't see this, maybe Philipp does, but he hasn't said anything yet.

In case I'm missing something, here's the full log of what I'm doing to verify that the l10n jars are there and listed in the manifest.
Only the chrome/calendar-AB-CD.jar files are present.
But all the chrome/lightning-AB-CD.jar files except en-US are missing, like lightning-cs.jar, lightning-de.jar, ... lightning-zh-TW.jar.
Ok, turns out this is all platforms and broke between 1.0b7 and 1.0rc1. Looking at it at the moment.
OS: Windows 7 → All
Hardware: x86 → All
Summary: L10n files (lightning-AB-CD.jar) missing in Lightning 1.0rc2 build1 → L10n files (lightning-AB-CD.jar) missing in Lightning 1.0rc builds
Lightning 1.0rc1 was OK, at least the win32 build.
Yeah, I was wrong earlier. It was just Mac 1.0rc1 that was broken, 1.0rc2 had all platforms broken. This was all fallout from bug 690560.
Assignee: nobody → mbanner
Blocks: 690560
Keywords: regression
Attached patch The fixSplinter Review
This should fix it - the issue was the lightning jars were ending up in the wrong place due to the lightning/locale directory being one deeper in level, because DIST was then wrong. The patch switches the repacks to use the absolute form of DIST and hence should work.

This has r=Fallen over irc.
Attachment #568896 - Attachment is obsolete: true
Attachment #569014 - Flags: review+
Looks like that patch fixed it, 1.0rc2 correctly contains the lightning l10n jars.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0b8
Yes, but I still need to check in the fix to trunk & aurora ;-)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
You need to log in before you can comment on or make changes to this bug.