float4.pow(x,y) asserts when jitting if the y param is a float4

VERIFIED DUPLICATE of bug 697066

Status

VERIFIED DUPLICATE of bug 697066
7 years ago
7 years ago

People

(Reporter: brbaker, Assigned: virgilp)

Tracking

unspecified
x86
Mac OS X
Bug Flags:
in-testsuite +
flashplayer-qrb +
flashplayer-bug -
flashplayer-triage +

Details

(Reporter)

Description

7 years ago
If the power parameter to float4.pow() is a float4 value and the code is jitted an assert is fired:

Code:
var flt4:float4 = new float4(1f);
float4.pow(flt4, flt4)


Assertion failed: "((t == (core->traits.uint_itraits)))" ("../core/CodegenLIR.cpp":7389)


#2  0x0000000100009da8 in avmplus::AvmDebugMsg (p=0x1002095f0 "Assertion failed: \"((t == (core->traits.uint_itraits)))\" (\"../core/CodegenLIR.cpp\":7389)\n", debugBreak=true) at ../AVMPI/AvmAssert.cpp:69
#3  0x000000010000980e in avmplus::AvmAssertFail (message=0x1002095f0 "Assertion failed: \"((t == (core->traits.uint_itraits)))\" (\"../core/CodegenLIR.cpp\":7389)\n") at AvmAssert.h:66
#4  0x0000000100000b56 in avmplus::_AvmAssertMsg (condition=0, message=0x1002095f0 "Assertion failed: \"((t == (core->traits.uint_itraits)))\" (\"../core/CodegenLIR.cpp\":7389)\n") at AvmAssert.h:72
#5  0x00000001000ae6ea in avmplus::CodegenLIR::promoteFloatIns (this=0x7fff5fbfea90, t=0x10109ab68, i=5) at ../core/CodegenLIR.cpp:7389
#6  0x00000001000b6f93 in avmplus::CodegenLIR::coerceToFloat (this=0x7fff5fbfea90, index=5) at ../core/CodegenLIR.cpp:3351
#7  0x00000001000b8f10 in avmplus::CodegenLIR::coerceToType (this=0x7fff5fbfea90, loc=5, result=0x10109a5a0) at ../core/CodegenLIR.cpp:4032
#8  0x00000001000bb313 in avmplus::CodegenLIR::emitCoerce (this=0x7fff5fbfea90, loc=5, result=0x10109a5a0) at ../core/CodegenLIR.cpp:3801
#9  0x00000001000bb36f in avmplus::CodegenLIR::writeCoerce (this=0x7fff5fbfea90, state=0x1010401d0, loc=5, result=0x10109a5a0) at ../core/CodegenLIR.cpp:3796
#10 0x00000001000d1691 in avmplus::NullWriter::writeCoerce (this=0x7fff5fbfe7d0, state=0x1010401d0, index=5, type=0x10109a5a0) at ../core/Coder.cpp:172
#11 0x000000010013bb49 in avmplus::Verifier::emitCoerce (this=0x7fff5fbfe880, target=0x10109a5a0, index=5) at ../core/Verifier.cpp:3037
#12 0x000000010013eb8d in avmplus::Verifier::emitCoerceArgs (this=0x7fff5fbfe880, m=0x10106d488, argc=2) at ../core/Verifier.cpp:3073
#13 0x000000010013f287 in avmplus::Verifier::emitCallpropertyMethod (this=0x7fff5fbfe880, opcode=avmplus::ActionBlockConstants::OP_callproperty, t=0x1010c7c90, b=0xb9, multiname=@0x7fff5fbfe1e0, multiname_index=43, argc=2, pc=0x1011a6c95 "F+\002???H\b\001") at ../core/Verifier.cpp:2680
#14 0x000000010013fa25 in avmplus::Verifier::emitCallproperty (this=0x7fff5fbfe880, opcode=avmplus::ActionBlockConstants::OP_callproperty, sp=@0x7fff5fbfe754, multiname=@0x7fff5fbfe1e0, multiname_index=43, argc=2, pc=0x1011a6c95 "F+\002???H\b\001") at ../core/Verifier.cpp:2643


Testmedia: as3/Types/Float4/flt4_4_4_16_13.as
Flags: in-testsuite+
Flags: flashplayer-triage+
Flags: flashplayer-qrb+
Flags: flashplayer-bug-
(Assignee)

Comment 1

7 years ago
there was another bug with this assertion - this is fixed now.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 697066
(Reporter)

Comment 2

7 years ago
verified fixed in 300:79e74cfec3ca
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.