Last Comment Bug 696297 - Valgrind job isn't using our suppressions file
: Valgrind job isn't using our suppressions file
Status: VERIFIED FIXED
[valgrind]
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86 Linux
: P3 normal (vote)
: mozilla15
Assigned To: Ed Morley [:emorley]
:
:
Mentors:
Depends on: 696299
Blocks: valgrind-on-tbpl 672046 696305
  Show dependency treegraph
 
Reported: 2011-10-20 18:47 PDT by Jesse Ruderman
Modified: 2012-04-30 05:58 PDT (History)
9 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (933 bytes, patch)
2012-04-27 05:37 PDT, Ed Morley [:emorley]
ted: review+
Details | Diff | Splinter Review

Description Jesse Ruderman 2011-10-20 18:47:51 PDT
https://tbpl.mozilla.org/php/getParsedLog.php?id=6905176&full=1&branch=mozilla-central#error0

args: ['/usr/bin/valgrind', '--error-exitcode=1', '--smc-check=all', '--gen-suppressions=all', '--leak-check=full', '--num-callers=50', '/builds/slave/m-cen-lnx64-valgrind/objdir/dist/firefox/firefox-bin', '-no-remote', '-profile', '/builds/slave/m-cen-lnx64-valgrind/objdir/_profile/pgo/pgoprofile/', 'http://localhost:8888/index.html']

(Note the lack of --suppressions=...)

Did we switch architectures since adding the suppressions file bug 631841? Or did bug 672046 break something?
Comment 1 Gary Kwong [:gkw] [:nth10sd] 2012-04-27 01:09:35 PDT
catlee, I looked in the log of:

https://tbpl.mozilla.org/php/getParsedLog.php?id=11226203&full=1&branch=mozilla-central

and there's still no --suppressions=<some .sup file> parameter. This portion of the patch in http://hg.mozilla.org/build/tools/rev/2bb5034bfca5 , it detects the suppression file at the correct location, no?

-suppression_file=_valgrind/${MACHTYPE}.sup
+suppression_file=$PWD/_valgrind/${MACHTYPE}.sup
 if [ -f $suppression_file ]; then
     debugger_args="$debugger_args --suppressions=$suppression_file"
 fi

Original patch was in bug 631841 comment 6.
Comment 2 Gary Kwong [:gkw] [:nth10sd] 2012-04-27 01:29:11 PDT
I'm probably just speculating, but could it be that the .sup file exits, but the path is incorrect?
Comment 3 Ted Mielczarek [:ted.mielczarek] 2012-04-27 05:18:40 PDT
bug 672046 broke this. We AC_SUBST(MOZ_VALGRIND) in configure.in, but we don't have a line for that in autoconf.mk.in, so it's not actually set as a Makefile var.
Comment 4 Ed Morley [:emorley] 2012-04-27 05:37:59 PDT
Created attachment 618998 [details] [diff] [review]
Patch v1
Comment 5 Ed Morley [:emorley] 2012-04-27 05:39:04 PDT
Sorry for breaking this! :-s
Comment 7 Ryan VanderMeulen [:RyanVM] 2012-04-29 14:00:26 PDT
http://hg.mozilla.org/mozilla-central/rev/f769cc9bd71c
Comment 8 Ted Mielczarek [:ted.mielczarek] 2012-04-30 05:58:46 PDT
This morning's build looks good:
https://tbpl.mozilla.org/php/getParsedLog.php?id=11320168&full=1&branch=mozilla-central

args: ['/usr/bin/valgrind', '--error-exitcode=1', '--smc-check=all', '--gen-suppressions=all', '--leak-check=full', '--num-callers=50', '--suppressions=/builds/slave/m-cen-lnx-valgrind/objdir/_valgrind/i686-redhat-linux-gnu.sup', '/builds/slave/m-cen-lnx-valgrind/objdir/dist/firefox/firefox-bin', '-no-remote', '-profile', '/builds/slave/m-cen-lnx-valgrind/objdir/_profile/pgo/pgoprofile/', 'http://localhost:8888/index.html']

Note You need to log in before you can comment on or make changes to this bug.