firefox disables latest version of flash

RESOLVED INCOMPLETE

Status

()

Firefox
General
--
major
RESOLVED INCOMPLETE
6 years ago
6 years ago

People

(Reporter: Hug Me, Unassigned)

Tracking

7 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2012-01-04])

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:7.0) Gecko/20100101 Firefox/7.0
Build ID: 20110922153450

Steps to reproduce:

install flash with the latest version.
I am running firefox 7.0
on linux kernel version 2.6.18-274.7.1.el5xen
which is CentOS release 5.7 (Final)
I've run a yum update on everything to make sure I have the latest version.
I have installed flash with yum, with rpm and by untaring it and installing by hand.
the manual install I used install_flash_player_11_linux.x86_64.tar.gz as the latest version I've just downloaded from adobe.
I have tried it with and without nswrapper


Actual results:

Flash is disabled with the message "For your safety, Firefox has disabled your outdated version of Flash. Please upgrade to the latest version."


Expected results:

flash should be working. This wouldn't be so bad if you were to give an option to go ahead and run flash. But there isn't one, you ASSUME that your auto-detect program is working fine... even when it's not. Give us an option to run flash any way and this would be fixed. I've looked on line and sifted through hundreds of emails to newsgroups about this problem in both linux and windows but nobody seems to have an answer.
(Reporter)

Updated

6 years ago
Severity: normal → major
Priority: -- → P3
Hardware: x86 → x86_64
If you are running the 32-bit version of Firefox, you need to also install the 32-bit version of flash.  It sounds like you might have only updated the 64-bit flash, which is not what the 32-bit Firefox would be using.
(Reporter)

Comment 2

6 years ago
It should be the 64 bit version. either way yum will know which one to install.

I have tried the 32 anyway. I downloaded install_flash_player_11_linux.i386.tar.gz and installed it, both with and without the wrapper and still receive the same problem.

As I mentioned before, if you would just give us a way to tell our browser not to use the broken plugin detector this would fix the problem.
(Reporter)

Comment 3

6 years ago
Also tested with yum

 yum list installed | grep firefox
firefox.x86_64                           3.6.23-2.el5.centos           installed
[root@vega kde4]# 

yum list installed | grep flash
flash-plugin.x86_64                      11.0.1.152-release            installed

 yum list installed | grep nsplugin
nspluginwrapper.x86_64                   1.3.0-9.el5                   installed

 yum list installed | grep curl
curl.i386                                7.15.5-9.el5_7.4              installed
curl.x86_64                              7.15.5-9.el5_7.4              installed
curl-devel.i386                          7.15.5-9.el5_7.4              installed
curl-devel.x86_64                        7.15.5-9.el5_7.4              installed
libcurl.i386                             7.21.7-5.el5.remi             installed
Please post the output of locate libflashplayer
Which flash plugin version is listed under tools/addons/plugins ?
Priority: P3 → --

Comment 5

6 years ago
Hug Me ??

(In reply to Matthias Versen (Matti) from comment #4)
> Please post the output of locate libflashplayer
> Which flash plugin version is listed under tools/addons/plugins ?
Whiteboard: [closeme 2012-01-04]

Comment 6

6 years ago
This issue also exists on OS X with FF 9 and 10. I have the latest Flash player installed, and all Flash content works correctly on other browsers. If I visit the Flash site the version available for update matches the version I have installed (10.3.183.11). This issue is clearly with the way that the plugin detector handles Flash versions. I agree that an option should be presented to users to keep using the 'outdated' version. 


Mozilla/5.0
Macintosh
Intel
Mac
OS
X
10.5
rv
10.0
Gecko/20100101
Firefox/10.0
No reply, INCOMPLETE. Please retest with Firefox 10 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.