If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

wrong rendering while using proxy

VERIFIED FIXED

Status

()

Core
Layout
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: kmike, Assigned: karnaze (gone))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
linux build 2001021921 (stumbled upon it in earlier builds, too),
squid-2.3.STABLE2-2.1mdk as http proxy.

with proxy on, load attached testcase. reload it, probably several times, until
you see the right image shifting outside inner and even outer table, like on
attached screenshot.

without proxy, testcase always renders correctly.

this happens even if i save html to local drive and open it using 'file://' url,
meaning that there's something wrong with images loading through proxy.

another note: if you press 'Enter' in location bar to reload testcase instead of
SHIFT-CTRL-R or SHIFT+Reload button, page will render correctly. 

my testcase was taken from www.m3dzone.com, where i first saw this.
(Reporter)

Comment 1

17 years ago
Created attachment 25793 [details]
testcase of incorrect rendering
(Reporter)

Comment 2

17 years ago
Created attachment 25794 [details]
screenshot of incorrect rendering

Comment 3

17 years ago
I can see this, too, with Mozilla 0.8 on NT4 (marking all/all).
I'm using a proxy but haven't tried without one.

For me the rendering was wrong only when loading the attachment for the first
time, after that it didn't happen again, even after clearing the cache.

Trying Layout component, don't know if that really has something to do with the
proxy configuration.
Assignee: darin → karnaze
Status: UNCONFIRMED → NEW
Component: Networking: HTTP → Layout
Ever confirmed: true
OS: Linux → All
QA Contact: tever → petersen
Hardware: PC → All

Comment 4

17 years ago
Hmm. I wonder if a slow modem connection will cause this as well? My guess is a
timing issue more than a proxy issue, especially considering it has to do with
images (and I know images that come in very slowly or very fast act differently,
at least pre-libpr0n).

Will investigate, but would like help trying to create a testcase that
reproduces this without a proxy, if it is possible. I was thinking that maybe
the images could be pulled from a bugzilla query or something...
(Reporter)

Comment 5

17 years ago
i can't reproduce it anymore using 2001051521 nightly linux build.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 6

17 years ago
Marking verified per last comments.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.