Last Comment Bug 696461 - Ux Designs For Primary UI
: Ux Designs For Primary UI
Status: RESOLVED FIXED
[QA+]
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P1 normal (vote)
: ---
Assigned To: Madhava Enros [:madhava]
:
: Sebastian Kaspari (:sebastian)
Mentors:
: 696901 (view as bug list)
Depends on: 699302
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-21 12:40 PDT by Erin Lancaster [:elan]
Modified: 2016-07-29 14:20 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
wire-mock of primary ui (250.44 KB, image/jpeg)
2011-10-25 14:07 PDT, Ian Barlow (:ibarlow)
no flags Details
Patch 1: Reskinning the primary ui (28.15 KB, patch)
2011-10-27 16:57 PDT, Sriram Ramasubramanian [:sriram]
mark.finkle: review+
Details | Diff | Splinter Review
Patch 2: Adding affordance to the browser bar (2.39 KB, patch)
2011-10-28 10:26 PDT, Sriram Ramasubramanian [:sriram]
no flags Details | Diff | Splinter Review
Screenshot 1: Adding affordance to the url bar (42.15 KB, image/png)
2011-10-28 10:27 PDT, Sriram Ramasubramanian [:sriram]
no flags Details

Description Erin Lancaster [:elan] 2011-10-21 12:40:33 PDT
Meta bug.
Comment 1 Ian Barlow (:ibarlow) 2011-10-25 14:07:13 PDT
Created attachment 569499 [details]
wire-mock of primary ui

More polished mocks and assets are on the way, but this should be enough to start with.
Comment 2 Mark Finkle (:mfinkle) (use needinfo?) 2011-10-27 09:44:20 PDT
*** Bug 696901 has been marked as a duplicate of this bug. ***
Comment 3 Sriram Ramasubramanian [:sriram] 2011-10-27 16:57:40 PDT
Created attachment 570120 [details] [diff] [review]
Patch 1: Reskinning the primary ui

This reskins the primary UI.

The values have been moved out of styles for 3 reasons:
1. There are issues with the order each attribute is applied in a relative layout-- and styles are confusing it a bit.
2. The amount of reusability has reduced, and it makes sense to cut down the styles.
3. The relative layout uses id's for placing the view items, and it better not placed in styles.

Todos:
1. The "Go" button in awesomebar
2. A back button in awesomebar -- in the place of "tabs" button
3. A lock button in browser-toolbar -- same as "Go" button.
--> This will be added as a separate patch once the resources are available for the same.
Comment 4 Sriram Ramasubramanian [:sriram] 2011-10-28 10:26:05 PDT
Created attachment 570296 [details] [diff] [review]
Patch 2: Adding affordance to the browser bar

I felt the address bar not having enough affordance to tap on it. And also a visual glitch when a text box with orange border is shown when we tap on it.
I tried adding back the original design of having text box background for the button.

Pros: 
  Has good affordance and removes the visual glitch while transitioning from address bar to editing it.

Cons:
  Loss of the simple, smooth and elegant design without the "bounding" box for the button.

Ian can decide on having this. Will be adding a screenshot of the same in a bit.
Comment 5 Sriram Ramasubramanian [:sriram] 2011-10-28 10:27:47 PDT
Created attachment 570298 [details]
Screenshot 1: Adding affordance to the url bar

This is a screenshot after applying Patch 2.
Comment 6 Mark Finkle (:mfinkle) (use needinfo?) 2011-10-28 10:36:16 PDT
Comment on attachment 570296 [details] [diff] [review]
Patch 2: Adding affordance to the browser bar

Waiting for ibarlow to ui+
Comment 7 Mark Finkle (:mfinkle) (use needinfo?) 2011-10-28 10:54:40 PDT
pushed the first patch:
https://hg.mozilla.org/projects/birch/rev/878512b3be8a

I think we should close this bug and move any other patches/ideas to new bugs
Comment 8 Aaron Train [:aaronmt] 2011-10-28 10:57:25 PDT
^ build failed 

https://tbpl.mozilla.org/php/getParsedLog.php?id=7084126&tree=Birch
Comment 9 Sriram Ramasubramanian [:sriram] 2011-10-28 10:59:50 PDT
Are we having a clean build? I reused a name with a different resource. That's causing the failure. If the obj directory is removed and compiled, the build is fine.
Comment 10 Mark Finkle (:mfinkle) (use needinfo?) 2011-10-28 11:56:28 PDT
(In reply to Aaron Train [:aaronmt] from comment #8)
> ^ build failed 
> 
> https://tbpl.mozilla.org/php/getParsedLog.php?id=7084126&tree=Birch

I tried using the Mozilla Clobberer, but it doesn't seem to have worked.

Note You need to log in before you can comment on or make changes to this bug.