Firefox constantly in Offline Mode

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: kid1000002000, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Ubuntu; X11; Linux i686; rv:10.0a1) Gecko/20111021 Firefox/10.0a1
Build ID: 20111021035716

Steps to reproduce:

Nothing.


Actual results:

Firefox nightly starts in offline mode in Ubuntu 11.10 and requires manual selection to force firefox into online mode. The toolkit.networkmanager.disable key is missing to prevent this from happening. Manual addition of the key does not solve the problem.


Expected results:

This should not have to happen.
Do you use Network Manager?

To correctly set the pref. Open about:config > right click choose new > boolean > name > toolkit.networkmanager.disable > true

http://kb.mozillazine.org/Toolkit.networkmanager.disable
(Reporter)

Comment 2

7 years ago
Yes, I do use Network Manager. I tried this, but it did not resolve the problem.
Note that the standard firefox install that comes with ubuntu 11.10 (firefox 7.0.1) does not exhibit this issue.

If I start firefox trunk in safe mode, the behavior is slightly different but still there. Using this method, the browser still starts in offline mode, but clicking "try again" bumps the browser into "online" mode.
(Reporter)

Comment 3

7 years ago
Also, using Wicd allows Firefox Nightly to behave normally, so the problem is definitely with network manager somewhere. I just don't know how to debug it...
(Reporter)

Comment 4

7 years ago
Setting network.manage-offline-status to False put a band-aid on the issue. However, I should not have to do this. I prefer using network manager over wicd, and I prefer using firefox nightlies over chrome, old firefox versions, etc.

Comment 5

5 years ago
Is this issue still reproducing for you with current Firefox builds? If so, please also try with a clean profile:
http://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
http://support.mozilla.org/en-US/kb/reset-preferences-fix-problems?esab=a&s=reset&r=0&as=s
Flags: needinfo?(kid1000002000)
(Reporter)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(kid1000002000)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.