If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Get rid of all gBrowser references in Mozmill

RESOLVED FIXED

Status

Testing Graveyard
Mozmill
RESOLVED FIXED
6 years ago
a year ago

People

(Reporter: ahal, Assigned: ahal)

Tracking

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
In desktop Firefox you can use the global gBrowser object to get a reference to the tabbedbrowser. In Fennec, this global object doesn't exist. Instead you need to call window.getBrowser();
(Assignee)

Comment 1

6 years ago
Created attachment 568785 [details] [diff] [review]
Patch 1.0 - Replace gBrowser with getBrowser()

This patch replaces all instances of gBrowser with getBrowser().
It passes all the mutt tests (js and python) in desktop Firefox. Note that most (if not all) mozmill tests will still fail in fennec due to chrome code touching content.
Attachment #568785 - Flags: review?(jhammel)

Updated

6 years ago
Blocks: 695026

Comment 2

6 years ago
Comment on attachment 568785 [details] [diff] [review]
Patch 1.0 - Replace gBrowser with getBrowser()

i'm surprised that's all there is but if it passes tests, looks good :)
Attachment #568785 - Flags: review?(jhammel) → review+

Comment 3

6 years ago
confirmed that this passes with mutt for me (linux 32, nightly)
(Assignee)

Comment 4

6 years ago
Yeah, I'm surprised it was that simple as well, though it makes sense since gBrowser is basically just a convenience object.

master: https://github.com/mozautomation/mozmill/commit/73a99688375719e300281d40f7693573e3dbd086
Assignee: nobody → ahalberstadt
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Depends on: 792807
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.