Last Comment Bug 696495 - texture-mips.html failures might be workaroundable by setting minification filter before glGenerateMipmap call
: texture-mips.html failures might be workaroundable by setting minification fi...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla14
Assigned To: Benoit Jacob [:bjacob] (mostly away)
:
Mentors:
Depends on:
Blocks: 750564
  Show dependency treegraph
 
Reported: 2011-10-21 14:46 PDT by Benoit Jacob [:bjacob] (mostly away)
Modified: 2012-04-30 17:22 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
workaround (4.01 KB, patch)
2011-10-21 14:58 PDT, Benoit Jacob [:bjacob] (mostly away)
jgilbert: review+
Details | Diff | Splinter Review
updated (1.60 KB, patch)
2012-04-19 07:03 PDT, Benoit Jacob [:bjacob] (mostly away)
jacob.benoit.1: review+
akeybl: approval‑mozilla‑central+
Details | Diff | Splinter Review

Description Benoit Jacob [:bjacob] (mostly away) 2011-10-21 14:46:32 PDT
See bug 695272 for an intermittent failure we've seen on linux. This is also permanently failing on mac.

See http://code.google.com/p/chromium/issues/detail?id=101105 for a possible workaround.

Thanks to Ken at Google.
Comment 1 Benoit Jacob [:bjacob] (mostly away) 2011-10-21 14:58:33 PDT
Created attachment 568790 [details] [diff] [review]
workaround

This is similar to http://codereview.chromium.org/8365018/

Tryserver push not ignoring this texture-mips test or assuming it to fail anywhere:
https://tbpl.mozilla.org/?tree=Try&rev=33979feed4f6
Comment 2 Benoit Jacob [:bjacob] (mostly away) 2012-01-24 11:34:26 PST
Comment on attachment 568790 [details] [diff] [review]
workaround

I'd like to land that now. It's still fixing test failures on the slaves.
Comment 3 Jeff Gilbert [:jgilbert] 2012-01-24 12:59:21 PST
We should also bother driver vendors about this.
Comment 4 Benoit Jacob [:bjacob] (mostly away) 2012-01-24 13:17:41 PST
http://hg.mozilla.org/integration/mozilla-inbound/rev/23ec123586ba
Comment 5 Benoit Jacob [:bjacob] (mostly away) 2012-01-24 14:40:24 PST
backed out:
https://hg.mozilla.org/integration/mozilla-inbound/rev/7030a479b0e3

at this point it looks like this is not needed.
Comment 7 Benoit Jacob [:bjacob] (mostly away) 2012-04-19 06:54:48 PDT
Results on webgl-driver-testing show that this seems really needed for many users on Windows with NVIDIA driver, even though this is somehow not needed on our test slaves.
Comment 8 Benoit Jacob [:bjacob] (mostly away) 2012-04-19 07:03:15 PDT
Created attachment 616552 [details] [diff] [review]
updated

updated, check WorkAroundDriverBugs(). carrying forward r+.

https://tbpl.mozilla.org/?tree=Try&rev=05b4b75b9f22
Comment 9 Benoit Jacob [:bjacob] (mostly away) 2012-04-19 19:20:01 PDT
Comment on attachment 616552 [details] [diff] [review]
updated

Please approve for mozilla-central. Needed for WebGL conformance on real-world drivers. Very safe. Only affects WebGL, which is not a priority for the upcoming Android release.
Comment 10 Benoit Jacob [:bjacob] (mostly away) 2012-04-19 20:36:15 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/eb53fd368324

Note You need to log in before you can comment on or make changes to this bug.