All theme aero/ directories are duplicates that should be merged into the main theme

RESOLVED DUPLICATE of bug 659407

Status

()

Firefox
Theme
--
minor
RESOLVED DUPLICATE of bug 659407
6 years ago
6 years ago

People

(Reporter: Jeremy Morton, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
I'm not sure why omni.jar's theme directories have an aero/ subdirectory which gets applied when Firefox is running on Aero, but as best I can tell it was probably implemented a while back before Firefox had the -moz-windows-theme CSS media selector.  Now that the selector's there, it seems that all aero/ stuff can and should be merged into the main theme, because at the moment it's just causing a bunch of duplicate (or near-duplicate) files to exist and bloat the download size, as well as make life tougher for theme developers (having to check changes in both the regular theme and the Aero theme).

Where we have stuff in aero/whatever.css files that isn't in the default theme files, it's saying "apply this stuff only in Aero".  Surely that is the same thing as enclosing these rules in:
@media all and (-moz-windows-theme: aero) {}

... in the main theme.

As for the stuff in aero/whatever.css files that is enclosed inside:
@media all and (-moz-windows-compositor) {}

... that's already only applying to Aero+glass, so there's no need for it to be in a separate 'Aero' theme.

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 659407
You need to log in before you can comment on or make changes to this bug.