Printing by selection cuts off first line

Assigned to



Printing: Output
7 years ago
4 years ago


(Reporter: Kostya, Assigned: Michael Ventnor)




Firefox Tracking Flags

(Not tracked)



(1 attachment)



7 years ago
Created attachment 568862 [details]

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_2) AppleWebKit/534.51.22 (KHTML, like Gecko) Version/5.1.1 Safari/534.51.22

Steps to reproduce:

1. Open
2. Select block of text
3. Choose File/Print/Print Selection

Actual results:

A page is printed with the first line cut in half.

The same issue with FF 7.0 in Windows and Mac (FF6.0 is OK).

Expected results:

All lines of the selection should print.

Comment 1

7 years ago
Mozilla/5.0 (X11; Linux x86_64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Mozilla/5.0 (X11; Linux x86_64; rv:8.0) Gecko/20100101 Firefox/8.0
Mozilla/5.0 (X11; Linux x86_64; rv:9.0a2) Gecko/20111022 Firefox/9.0a2
Mozilla/5.0 (X11; Linux x86_64; rv:10.0a1) Gecko/20111022 Firefox/10.0a1

Last good nightly: 2011-06-10
First bad nightly: 2011-06-11

OS: Mac OS X → All
Hardware: x86 → All
Version: 7 Branch → Trunk


7 years ago
Keywords: regression

Comment 2

7 years ago
Local track down using Linux:

The first bad revision is:
changeset:   70871:251688029a9d
parent:      70854:1e3af440ce23
user:        Michael Ventnor <>
date:        Fri Jun 10 20:07:26 2011 +1000
summary:     Bug 663028 - Make Print Preview themable with CSS, and modernize its look r=roc
Blocks: 663028
Component: General → Printing: Output
Product: Firefox → Core
QA Contact: general → printing


7 years ago
Ever confirmed: true
Assignee: nobody → ventnor.bugzilla

Comment 3

7 years ago
OK, I've finally pinpointed the culprit, it's to do with clipping that we do for the page content frame, in a bit of code I didn't touch.
Now to see how to fix this.

Comment 4

7 years ago
I still haven't figured out what is going wrong with the clipping, none of the variables involved were touched by my patch.

I'm not surprised this is to do with print selection, perhaps the most broken and badly written feature in the codebase aside from mork.


6 years ago
Duplicate of this bug: 714006

Comment 6

6 years ago
Seems all has gone quiet with this Bug, which is a shame as it is a serious restriction to users.

To add extra input to this issue:

I am using Firefox Firefox 10.05b (OS: Win XP Home Sp3)

1) I confirm the clipped first line when using "Print Selection". 
HOWEVER I have noted that the printout ALWAYS includes the next word or few words that come after the Actually Selected text (i.e IF USER HAS selected text to mid line rather than a whole paragraph which has spaces after it) 

2) I have also noted when printing a Webpage or "Print ALL" where the webpages  have an "Ads by Google" and links row included, that upon "Print Previewing" the "Ads by Google" row is severely clipped (as with first row of Print Selection)
HOWEVER all the rest of the Webpage ABOVE of BELOW are normal in Preview AND the page(s) print out correctly, EXCEPT the "Ads By Google" row, which is clipped.

I have no idea if there is a connection between 1) and 2) but Print Selection seems to clip on all webpages whether that "Ads by Google" row is there or not.

I get around 2) with use of Adblock Plus which seems to block that "Ads by Google" row appearing which is no loss to me. 

Most users use Print "selection" (whether frequently or infrequently) and "Print Selection" IMHO is pretty useless as it stands, with the first line severely clipped and extra word(s)added to the last line (if not end of a paragraph).   

I have checked IE8 and neither problem 1) or 2) occurs.

Hope this helps


6 years ago
Duplicate of this bug: 730258

Comment 8

6 years ago
Report bug 730258 is not entirely a duplicate. Its main problem is not the first line, but the lines vertically split across pages.

Comment 9

6 years ago
This may or may not be the same bug, but the test mentioned at the top of this thread result in NO selected text being printed at all.  This is with FF 11.0.

Comment 10

5 years ago
This is STILL broke on FF 17.0.1  It works fine on IE.

Comment 11

5 years ago
Mozilla/5.0 (X11; Linux x86_64; rv:21.0) Gecko/20130115 Firefox/21.0

Comment 12

5 years ago
Someone (John99) claims that this bug has been fixed in some nightlys and the fix will be released with Firefox 21:
I think he must be confused. There's no indication that this bug is fixed, and I can still reproduce this in Nightly (selecting the first two paragraphs in the article linked in comment 0).

So, not fixed yet.

Mozilla/5.0 (X11; Linux x86_64; rv:22.0) Gecko/20130315 Firefox/22.0

Comment 14

5 years ago
I have reported issues with "Selection Printing a long time ago (many releases back)regarding Line clipping AND I ALSO reported at the time the "Selection"  does not always print true to the EXACT place at the end of the selection (i.e. if selection was mid line of text the subsequent print MAY have a bit more or less text than the actual selected text.   and many releases back (as have many other users). this problem has been around for well over a year maybe two yet development has continued at breakneck speed whilst something used by so many and so often has been essentially ignored.  

PLEASE DON'T GET ME WRONG. I think all the developers who work on Firefox do a MAGNIFICENT job on Firefox, which I consider to be the best and most customizable Browser BY FAR. HOWEVER, I do feel it needs someone to decide when a bug is so significant and of so much an issue and annoyance to so many/most users that BEFORE further new advances are worked on, basic requirements expected of ALL Browsers are working as they should or are fixed to work as they should.

It is really annoying that select print is so poor on such a wonderful product.

I use the Beta version of Firefox and have done so for a long time I find the Beta versions very stable. I sometime look at the3 Aurora and Beta Web Pages and I note some issues are carried over for many builds without being fixed. Surely recognized & accepted issues should be a priority over new development. I, of course, appreciate development and fixes are worked on in parallel by different developers/groups of developers.

As Don says above, IE Selection Printing works fine and as far as I am aware has done so since IE came on the scene. It seems only Firefox (out of the main Browsers) has this "Selection Print" issue.

Comment 15

5 years ago
My apologies for the poor text in places above.  
My young son :) clicked on "Save Changes" whilst I was in the process of "proofing" the post.

Comment 16

4 years ago
I'm not sure if this is needed but this I can confirm this bug still exists as of version 25.0.1. Quite a feat surviving since version 5. If I knew how to help, I'd have at it. If anyone is actually reading this and does help, thank you very much. I owe you a beer.

Comment 17

4 years ago
And it is still happening in version 31.0
You need to log in before you can comment on or make changes to this bug.