crash when trying to edit image properties

VERIFIED WORKSFORME

Status

()

Core
Editor
P2
critical
VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: R.K.Aa., Assigned: Brade)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
2001022021 linux

-Load http://counter.li.org
-Click menu File -> Edit page (composer opens with the page)
-Right-click the image of a penguin
-Select "image properties"
-Crash

Not URL in url-field of bug, since this happens to me with almost any html-page
with images now - local and external.

0x40a944c2 in nsHTMLImageElement::GetComplete () from
/usr/local/mozilla/components/libgkcontent.so

I don't know if this is related to the whole context menu appearantly being
horked these days (lots of items missing, a random "j" added etc.) There are
also many errors as composer is initially started, and when context-menu is
called, like these:

failed to get command manager number 3
failed to get command manager number 2
JavaScript error: 
 line 0: uncaught exception: [Exception... "Component returned failure code:
0x80004001 (NS_ERROR_NOT_IMPLEMENTED) [nsIEditorShell.GetSelectedElement]" 
nsresult: "0x80004001 (NS_ERROR_NOT_IMPLEMENTED)"  location: "JS frame ::
chrome://editor/content/editor.js :: GetObjectForProperties :: line 970"  data: no]
************************************************************
An error occurred updating the cmd_objectProperties command
************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "Can not find interface information for parameter arg 0
[nsIEditorShell.editorSelection]"  nsresult: "0x80570006
(NS_ERROR_XPC_CANT_GET_PARAM_IFACE_INFO)"  location: "JS frame ::
chrome://editor/content/editor.js :: GetObjectForProperties :: line 977"  data: no]
************************************************************
An error occurred updating the cmd_objectProperties command
Document http://www.mozilla.org/ loaded successfully
JavaScript error: 
 line 0: uncaught exception: [Exception... "Can not find interface information
for parameter arg 0 [nsIEditorShell.editorSelection]"  nsresult: "0x80570006
(NS_ERROR_XPC_CANT_GET_PARAM_IFACE_INFO)"  location: "JS frame ::
chrome://editor/content/editor.js :: InitRemoveStylesMenuitems :: line 2075" 
data: no]

JavaScript error: 
 line 0: uncaught exception: [Exception... "Can not find interface information
for parameter arg 0 [nsIEditorShell.editorSelection]"  nsresult: "0x80570006
(NS_ERROR_XPC_CANT_GET_PARAM_IFACE_INFO)"  location: "JS frame ::
chrome://editor/content/EdLinkProps.js :: Startup :: line 68"  data: no]

Comment 1

18 years ago
assigning to cmanske
Assignee: beppe → cmanske
Keywords: crash
Priority: -- → P2

Comment 2

18 years ago
this also crashes on win32, will attach the talkback report when it is 
accessible

Comment 3

18 years ago
Created attachment 25811 [details]
talkback (win32, 2001022020)
(Reporter)

Comment 4

18 years ago
Created attachment 25829 [details]
backtrace on non-debug linux trunk SEA 2001022021
(Reporter)

Comment 5

18 years ago
*** Bug 69948 has been marked as a duplicate of this bug. ***

Comment 6

18 years ago
To clarify something...As I noted in the dup (bug 69948) the Image Properties
dialog doesn't crash UNTIL the URL field contains a filename.

 rkaa's stack seems to indicate that the trouble's involved in or following
retrieval of the image(Though the image does indeed appear in the window a
split-second before segfault, if the field contains a valid filename)...Though I
could be wrong...

 It would certainly explain why Mozilla won't die if you feed the dialog an
Image URL that doesn't have an extension of .gif/.png/.jpg-It'd only come up in
the case it could handle. But maybe I'm being too obvious...

Comment 7

18 years ago
No, your comments are useful! I suspected the problem involves getting the image
for the preview display in the dialog. The error is probably in image code.
But I have not been able to reproduce this on Windows (NT).
Brade has volunteered to explore this: please check on all platforms.

Assignee: cmanske → brade

Comment 8

18 years ago
Looks like WFM on Linux tar.gz build, 2001022321. (What a relief!)

 Confirm, someone?
(Reporter)

Comment 9

18 years ago
Confirming. In 2001022321 linux SEA, i see no crash anymore. Resolving as WFM.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 10

18 years ago
verified in 2/26 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.