Last Comment Bug 696618 - Spreadsheet of Google Docs stop response for a while when I input values continuously
: Spreadsheet of Google Docs stop response for a while when I input values cont...
Status: RESOLVED FIXED
: perf, regression
Product: Core
Classification: Components
Component: Editor (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 684638
Blocks: 674212
  Show dependency treegraph
 
Reported: 2011-10-22 18:54 PDT by Alice0775 White
Modified: 2012-01-03 12:54 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
-


Attachments

Description Alice0775 White 2011-10-22 18:54:25 PDT
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/e79245e249c4
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111022 Firefox/10.0a1 ID:20111022031010

Spreadsheet of Google Docs stop response for a while when I input values continuously.

This happens on Aurora9.0a2 and Nightly10.0a1.

This does not happen Firefox8.0bata

Reproducible: Always

Steps to Reproduce:
1. Start Minefield with new profile
2. Open URL ( http://www.youtube.com/watch?v=K7l0a2PVhPQ&feature=player_embedded )
3. Open https://docs.google.com and login
4. CREATE > Spreadsheet

5. Select a cell
6. Keyin
   1 Enter 1 Enter 1 Enter 1 Enter .... (repeat rapidly)


Actual Results:
 Spreadsheet of Google Docs stop response for a while with 100%CPU core.

Expected Results:
 Should not.

Regression window(m-i):
Works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/05268baefef7
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110817 Firefox/9.0a1 ID:20110817115336
Fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/800f7541fb20
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110817 Firefox/9.0a1 ID:20110817141601
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=05268baefef7&tochange=800f7541fb20

Suspected:
800f7541fb20	Fabien Cazenave — Bug 674212 - Modifying text of a contenteditable DOM Node removes spellcheck underlinings; r=ehsan


Maybe this is caused by a same reason of Bug 684638 .
Comment 1 Boris Zbarsky [:bz] (TPAC) 2011-10-25 10:26:03 PDT
This sounds really bad... Fabien, can you take a look?
Comment 2 Bill Gianopoulos [:WG9s] 2011-11-03 06:15:49 PDT
Could someone who experiences this try the builds here?

http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/bzbarsky@mozilla.com-5a1c9caa43d8/

These include the proposed fix for bug 684638. It would be useful to determine if they fix this issue as well.
Comment 3 Alice0775 White 2011-11-03 06:21:21 PDT
(In reply to Bill Gianopoulos from comment #2)
> Could someone who experiences this try the builds here?
> 
> http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/bzbarsky@mozilla.
> com-5a1c9caa43d8/
> 
> These include the proposed fix for bug 684638. It would be useful to
> determine if they fix this issue as well.

I confirmed that the try server build fixed the problem.
Comment 4 Boris Zbarsky [:bz] (TPAC) 2011-11-03 06:25:48 PDT
> I confirmed that the try server build fixed the problem.

Thank you for checking that!
Comment 5 Bill Gianopoulos [:WG9s] 2011-11-04 04:50:28 PDT
Fixed by check-in for bug 684638.
Comment 6 Alex Keybl [:akeybl] 2012-01-03 12:54:15 PST
Fixed in FF9/10 in bug 684638.

Note You need to log in before you can comment on or make changes to this bug.