Etherpad MoPad update breaks horizontal scrolling

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
7 years ago
3 years ago

People

(Reporter: richard, Unassigned)

Tracking

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111019081014

Steps to reproduce:

Create a new etherpad or open an existing one.
Resize the browser window so that it is narrower than the etherpad.

...or....

open http://htmlpad.org


Actual results:

A horizontal scroll bar appears at the bottom of the screen, but it does not allow scrolling far enough to see the left edge of the pad.

Note that this problem breaks htmlpad by making it impossible to edit code even with a full screen browser window.


Expected results:

The scroll bar should enable scrolling to the left edge of the etherpad.
(Reporter)

Updated

7 years ago
Component: Web Site → General
Component: General → Other
Product: Mozilla Services → Websites
QA Contact: website → other

Comment 1

7 years ago
At a glance I'd say this is directly related to this upstream issue:

https://github.com/ether/pad/issues/202


Since there currently is no web dev assigned to Etherpad, I'll take this for now. In the near future we'll probably be setting up a staging instance of Etherpad to deal with strange things like this.

For the record, I believe this is the relevant CSS:

https://github.com/ether/pad/blob/master/etherpad/src/static/css/pad2_ejs.css
Assignee: nobody → nmaul
Status: UNCONFIRMED → NEW
Component: Other → Server Operations: Web Operations
Ever confirmed: true
Product: Websites → mozilla.org
QA Contact: other → cshields
Version: unspecified → other

Comment 2

7 years ago
There actually are some webdev resources for Etherpad now, although mainly focused on BrowserID. However, there may be some time available to look into fixing this. It looks like a relatively simple CSS issue, although I'm not sure what a better solution to the problem at hand really is. A more seasoned web dev should be able to sort this out faster than I can.
Assignee: nmaul → nobody
Component: Server Operations: Web Operations → Other
Product: mozilla.org → Websites
QA Contact: cshields → other

Updated

7 years ago
Component: Other → etherpad.mozilla.org
QA Contact: other → etherpad-mozilla-org

Comment 3

6 years ago
htmlpad.org is actually completely broken at the moment, possibly because it insists on reaching etherpad via http://, and etherpad enforces a redirect to https://. In any case I can't even start editing, it just loops on the "create this pad" button/page.

Fortunately bug 698034 is relevant here. This might be solvable by combined tweaking of htmlpad and etherpad.
Depends on: 698034

Comment 4

3 years ago
This component is no longer being tracked and its bugs are being closed and moved to the Websites Graveayard product.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

3 years ago
Product: Websites → Websites Graveyard
You need to log in before you can comment on or make changes to this bug.