Last Comment Bug 696683 - handleGeckoMessage throws java.lang.NullPointerException on startup
: handleGeckoMessage throws java.lang.NullPointerException on startup
Status: RESOLVED FIXED
: crash
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All All
: P2 critical (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-23 17:05 PDT by Doug Turner (:dougt)
Modified: 2012-01-09 14:51 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
patch (653 bytes, patch)
2011-10-24 10:23 PDT, [:fabrice] Fabrice Desré
dougt: review+
Details | Diff | Splinter Review

Description Doug Turner (:dougt) 2011-10-23 17:05:48 PDT
Stack:

E/GeckoShell(23007): org.mozilla.gecko.GeckoApp.handleDocumentStart(GeckoApp.java:493)
E/GeckoShell(23007): org.mozilla.gecko.GeckoAppShell.handleGeckoMessage(GeckoAppShell.java:1609)
E/GeckoShell(23007): org.mozilla.gecko.GeckoAppShell.nativeRun(Native Method)
E/GeckoShell(23007): org.mozilla.gecko.GeckoAppShell.nativeRun(Native Method)
E/GeckoShell(23007): org.mozilla.gecko.GeckoAppShell.runGecko(GeckoAppShell.java:420)
E/GeckoShell(23007): org.mozilla.gecko.GeckoApp$1GeckoTask.doInBackground(GeckoApp.java:357)
E/GeckoShell(23007): org.mozilla.gecko.GeckoApp$1GeckoTask.doInBackground(GeckoApp.java:303)
E/GeckoShell(23007): android.os.AsyncTask$2.call(AsyncTask.java:185)
E/GeckoShell(23007): java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:306)
E/GeckoShell(23007): java.util.concurrent.FutureTask.run(FutureTask.java:138)
E/GeckoShell(23007): java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1088)
E/GeckoShell(23007): java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:581)
E/GeckoShell(23007): java.lang.Thread.run(Thread.java:1019)
Comment 1 [:fabrice] Fabrice Desré 2011-10-24 10:23:29 PDT
Created attachment 569102 [details] [diff] [review]
patch

The expection is raised because we're asking for a non existent tab.
We receive a "document start" before creating the first tab, which is probably what need to be really fixed.
Comment 2 Mark Finkle (:mfinkle) (use needinfo?) 2011-10-24 10:58:34 PDT
Sounds like this is the same kinda error we see on XUL fennec when the "about:blank" page of a new tab fires off an event of two.

Wonder if this _is_ the case and if so, could we stop sending the messaging in JS?
Comment 3 [:fabrice] Fabrice Desré 2011-10-24 14:10:05 PDT
pushed:
http://hg.mozilla.org/projects/birch/rev/1d37f263df5f

Note You need to log in before you can comment on or make changes to this bug.