Closed Bug 696746 Opened 9 years ago Closed 9 years ago

Remove +1 in DocumentViewerImpl::SizeTo

Categories

(Core :: Layout, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 230959

People

(Reporter: enndeakin, Assigned: enndeakin)

Details

Attachments

(1 file)

Attached patch patchSplinter Review
Some code in DocumentViewerImpl::SizeTo adds one to the width in case of rounding issues, but sometimes this causes an extra reflow. I'm not sure whether the issue that caused this code to be added still exists, but we can at least only have the extra one added when the width isn't an integer, reducing the number of extra reflows in some cases.
Attachment #569040 - Flags: review?(roc)
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 230959
Product: Core → Core Graveyard
Component: Layout: Misc Code → Layout
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.