Change Highlighter's shortcut key to Ctrl/Cmd-Alt-i

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
7 years ago
5 months ago

People

(Reporter: rcampbell, Assigned: rcampbell)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
change the key from ctrl/cmd-shift-i to ctrl/cmd-alt-i.
(Assignee)

Comment 1

7 years ago
Created attachment 569074 [details] [diff] [review]
alt key
Assignee: nobody → rcampbell
Status: NEW → ASSIGNED
Attachment #569074 - Flags: review?(gavin.sharp)
Why?
I vaguely recall Ctrl+Alt shortcuts being reserved on Windows and/or Linux.
(In reply to Gavin Sharp (use gavin@gavinsharp.com for email) from comment #3)
> I vaguely recall Ctrl+Alt shortcuts being reserved on Windows and/or Linux.

That's correct.
Comment on attachment 569074 [details] [diff] [review]
alt key

For instance, with my German keyboard on Win XP, Alt+Ctrl+E is € and Alt+Ctrl+M is µ. Alt+Ctrl+I could have a similar meaning in other locales.
Attachment #569074 - Flags: review?(gavin.sharp) → review-
(Assignee)

Comment 6

7 years ago
(In reply to Dão Gottwald [:dao] from comment #5)
> Comment on attachment 569074 [details] [diff] [review] [diff] [details] [review]
> alt key
> 
> For instance, with my German keyboard on Win XP, Alt+Ctrl+E is € and
> Alt+Ctrl+M is µ. Alt+Ctrl+I could have a similar meaning in other locales.

ugh. right.

(In reply to Gavin Sharp (use gavin@gavinsharp.com for email) from comment #2)
> Why?

Cmd-shift-I conflicts with DOM Inspector. Pretty sure Chrome uses Cmd-alt-I.
Ultimatively it's DOMi's responsibility to deal with this... and overriding a built-in shortcut when providing a similar feature is a legitimate outcome.
(Assignee)

Comment 8

7 years ago
(In reply to Dão Gottwald [:dao] from comment #7)
> Ultimatively it's DOMi's responsibility to deal with this... and overriding
> a built-in shortcut when providing a similar feature is a legitimate outcome.

Yep, it is and I applaud their continued use of their shortcut key.

I just wish I could change one of them so I don't keep accidentally opening DOM inspector when I want to open the built-in highlighter. :)
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Resolution: FIXED → WONTFIX

Updated

7 years ago
Duplicate of this bug: 689924

Updated

5 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.