If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[prod] ISE : UndefinedError: 'gravatar_img' is undefined

VERIFIED WORKSFORME

Status

Firefox Affiliates Graveyard
affiliates.mozilla.org
--
blocker
VERIFIED WORKSFORME
6 years ago
2 years ago

People

(Reporter: mbrandt, Unassigned)

Tracking

unspecified
x86
Mac OS X

Details

(Whiteboard: [prod])

(Reporter)

Description

6 years ago
There is a new spate of traceback emails - Some of the offending uris in the case of the following traceback are /en-US/faq, /pt-BR/new, pt-BR/banners/customize/3, etc.


===================================================


Traceback (most recent call last):

 File "/data/www/affiliates.mozilla.org/affiliates-app/vendor/src/django/django/core/handlers/base.py", line 111, in get_response
   response = callback(request, *callback_args, **callback_kwargs)

 File "/data/www/affiliates.mozilla.org/affiliates-app/apps/shared/decorators.py", line 11, in decorator
   return view_func(request, *args, **kwargs)

 File "/data/www/affiliates.mozilla.org/affiliates-app/apps/shared/views.py", line 12, in faq
   return dashboard(request, 'shared/faq.html')

 File "/data/www/affiliates.mozilla.org/affiliates-app/apps/shared/decorators.py", line 11, in decorator
   return view_func(request, *args, **kwargs)

 File "/data/www/affiliates.mozilla.org/affiliates-app/apps/badges/views.py", line 115, in dashboard
   return jingo.render(request, template, context)

 File "/data/www/affiliates.mozilla.org/affiliates-app/vendor/src/jingo/jingo/__init__.py", line 80, in render
   rendered = render_to_string(request, template, context)

 File "/data/www/affiliates.mozilla.org/affiliates-app/vendor/src/jingo/jingo/__init__.py", line 98, in render_to_string
   return template.render(**get_context())

 File "/usr/lib/python2.6/site-packages/jinja2/environment.py", line 891, in render
   return self.environment.handle_exception(exc_info, True)

 File "/data/www/affiliates.mozilla.org/affiliates-app/apps/shared/templates/shared/faq.html", line 3, in top-level template code
   {% set content_section = 'second-section' %}

 File "/data/www/affiliates.mozilla.org/affiliates-app/templates/dashboard.html", line 3, in top-level template code
   {% set user = request.user %}

 File "/data/www/affiliates.mozilla.org/affiliates-app/templates/base.html", line 47, in top-level template code
   {% block sidebar %}

 File "/data/www/affiliates.mozilla.org/affiliates-app/templates/base.html", line 49, in block "sidebar"
   {% block sidebar_content %}{% endblock %}

 File "/data/www/affiliates.mozilla.org/affiliates-app/templates/dashboard.html", line 23, in block "sidebar_content"
   {% include 'badges/include/sidebar_profile.html' %}

 File "/data/www/affiliates.mozilla.org/affiliates-app/apps/badges/templates/badges/include/sidebar_profile.html", line 5, in top-level template code
   {{ gravatar_img(user, size=50) }}

UndefinedError: 'gravatar_img' is undefined
Could not reproduce this issue. We restarted apache on prod as part of a push and haven't received any tracebacks since then. This was probably just a screwed up instance.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

6 years ago
Thanks mkelly, kicking Apache seems to have resolved the issue. I'll reopen/refile if this appears again.

Verified worksforme.
Status: RESOLVED → VERIFIED
(Reporter)

Updated

6 years ago
Target Milestone: --- → 1.1
(Assignee)

Updated

5 years ago
Product: Websites → Firefox Affiliates
(Assignee)

Updated

2 years ago
Product: Firefox Affiliates → Firefox Affiliates Graveyard
You need to log in before you can comment on or make changes to this bug.