Sender (Inbox) and recipient (Sent) names don't match those in the message source, which are not added to address book. Name in address book is shown at thread pane.

RESOLVED DUPLICATE of bug 672966

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 672966
7 years ago
7 years ago

People

(Reporter: David Merrill, Unassigned)

Tracking

7 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dupme)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/535.2 (KHTML, like Gecko) Chrome/15.0.874.102 Safari/535.2

Steps to reproduce:

I received a message from Marshall, and then I replied to it, and expected to find him in my address book thereafter.


Actual results:

Marshall's name is visible in the message source (e.g., Marshall <graphics@newspaper.com>) in both Inbox and Sent folders, but the "From:" line in the inbox message display, the "To:" line in the sent message display, and the related columns in both message lists say the message came from and was sent to Nina, who used to have that email address and is still in one of my (old) address books (e.g., Nina <graphics@newspaper.com>). IN ADDITION, even though Marshall's name showed correctly in the composition window when I replied, it was not added to my address book.


Expected results:

The name in all message displays should match that in the message, even if an address book entry exists with a different name for that address. And if I send a message to person X with the same address as but different name from person Y, the address should be added to my address book with the new name, and all displays of that message should match the address that's actually in the message.

Comment 1

7 years ago
(In reply to David Merrill from comment #0)
> in one of my (old) address books (e.g., Nina <graphics@newspaper.com>). IN
> ADDITION, even though Marshall's name showed correctly in the composition
> window when I replied, it was not added to my address book.
I think you have to add it manually in the address book.
Whiteboard: dupme
(In reply to David Merrill from comment #0)
> Expected results:
> The name in all message displays should match that in the message, even if
> an address book entry exists with a different name for that address.

By default change and/or unplesant default of new feature, next is usually forced.
> if an address book entry exists for that address,
> show name in address book instead of name or mail-addr in message header.
Fortunately, it's not applicable to mail composition window.
Even if due to defaulted, once set, it's user's choice for Tb.
See Whiteborard: field of bug 672966 for recovery operation, please.

By the way, if first report of a problem were always one like report by you, problem determination work by QA peoples would be needless :-)
Closing as dup of bug 672966, because main issue in comment #0 is bug 672966.
Open separate bug for issues which you are experiencing, which are different from that bug, please, because "one problem per a bug" is rule at B.M.O.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Summary: Sender (Inbox) and recipient (Sent) names don't match those in the message source, which are not added to address book. → Sender (Inbox) and recipient (Sent) names don't match those in the message source, which are not added to address book. Name in address book is shown at thread pane.
Duplicate of bug: 672966
You need to log in before you can comment on or make changes to this bug.