Closed Bug 696936 Opened 8 years ago Closed 4 years ago

"ASSERTION: Perspective must be positive!" (quirks mode only)

Categories

(Core :: CSS Parsing and Computation, defect)

x86_64
macOS
defect
Not set

Tracking

()

RESOLVED WORKSFORME
Tracking Status
b2g-v2.5 --- fixed

People

(Reporter: jruderman, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, testcase)

Attachments

(2 files)

Attached file testcase
###!!! ASSERTION: Perspective must be positive!: 'aDepth > 0.0f', file gfx/thebes/gfx3DMatrix.cpp, line 247

In standards mode, the CSS parser rejects the negative value.  But in quirks mode, it doesn't.  Why not?
Attached file stack trace
No longer asserts on trunk.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: in-testsuite+
Resolution: --- → WORKSFORME
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 725036
Er, never mind, this was the function.
Resolution: DUPLICATE → WORKSFORME
You need to log in before you can comment on or make changes to this bug.