Nested Frameset cannot be resized in JavaScript

VERIFIED DUPLICATE of bug 69347

Status

()

Core
DOM: Core & HTML
VERIFIED DUPLICATE of bug 69347
17 years ago
4 years ago

People

(Reporter: aogun, Assigned: Eric Pollmann)

Tracking

({dom0, testcase})

Trunk
mozilla1.0
x86
Windows NT
dom0, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
The text for three files is enclosed.  These create a frameset nested within a 
another frameset. When one of the frames is loaded, it attempts to modify the 
dimensions of the rows within the frameset.  

The expected behavior is that the frameset on the right side of the screen 
should make the top frame smaller (to 20%) and the bottom frame bigger, as soon 
as the page loads.

The milestone build of Mozilla does nothing (the top frame remains bigger than 
the bottom frame); while Netscape 6 indicates an exception in the JavaScript 
console [Exception... "Unexpected error" code:"-2147418113" 
nsresult:NS_ERROR_UNEXPECTED"].

These three files should be in the same folder.  View File 1 to produce the bug.
------------------------ File 1: ns6frameset.html -----------------------
<html>
<head>
</head>
<frameset name="mainframeset" cols="50%,50%">
	<frame name="nothingframe" src="detail.html" scrolling="auto">
	<frameset name="rightframeset" id="rightframeset" rows="77%,*">';
		<frame name="top" src="ns6test.html" scrolling="auto">
		<frame name="DCS" src="detail.html" scrolling="auto">
	</frameset>
</frameset>
</html>

----------------------------- File 2: detail.html -----------------------------
<html>
</html>

-----------------------------File 3: ns6test.html -----------------------------
<html>
<head>
<script>
function onLoad()
{
	parent.document.getElementById("rightframeset").rows = "20%,*";
}
</script>
</head>
<body onload="onLoad()">
<DIV ID="number1" ALIGN="left">
<DIV>
</body>
</html>

Comment 1

17 years ago
Browser, not engine. Reassigning to DOM Level 0 for further triage - 
Assignee: rogerl → jst
Component: Javascript Engine → DOM Level 0
QA Contact: pschwartau → desale
IIRC this is a dupe of one of pollmanns bugs, reassigning.
Assignee: jst → pollmann
Keywords: dom0

Comment 3

17 years ago
Dependent on 61648?
Severity: major → normal

Updated

17 years ago
Whiteboard: DUPE ME

Comment 4

17 years ago
Much frame happiness with recent builds. Reporter, is this still an issue?

Comment 5

17 years ago
This bug affects mozilla0.9 but it seems that if the mainframeset's cols
attribute is changed the frameset will resize.

Comment 6

17 years ago
Created attachment 35558 [details]
frame for testcase

Comment 7

17 years ago
Created attachment 35559 [details]
frame2 for testcase

Comment 8

17 years ago
Created attachment 35561 [details]
actual testcase

Comment 9

17 years ago
For attachment 35561 [details]:

click on "Resize Sub Frameset 20% *"

expected result: frame resizes
actual result: nothing happens

click on "Resize Sub Frameset 20% *"
click on "Resize Main Frameset 20% 80%"

expected result: both frame resizes
actual result: both frame resizes

Comment 10

17 years ago
Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
Whiteboard: DUPE ME

Updated

17 years ago
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 11

17 years ago
This bug reports the same issue as bug 69347.  I'll note there to also verify
the fix with this testcase.

*** This bug has been marked as a duplicate of 69347 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 12

17 years ago
Verified Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.