Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Attachments: single attachment opens on single click, multiple attachments need double click

RESOLVED FIXED in Thunderbird 17.0

Status

Thunderbird
Message Reader UI
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: DutchGemini, Assigned: squib)

Tracking

({ux-consistency})

7 Branch
Thunderbird 17.0
x86
Windows XP
ux-consistency

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; Avant Browser; Avant Browser; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET CLR 1.1.4322)

Steps to reproduce:

I received a message with either a single or with multiple attachments.


Actual results:

If there is a single attachment then you only click once to open, but if there are multiple then you need to open the indicator (goes also with single click) and then you must doubleclick on each attachment to open it. If you doubleclick on a single attachment, 2 instances of the handling application start (eg. Acrobat Reader) showing the *same* attachment.


Expected results:

I expected to use a doubleclick only also for opening single attachment. This is consistent with the rest of Windows.
(Assignee)

Comment 1

6 years ago
This isn't a question of consistency (at least not in the way you're suggesting). Double-clicking to open is usually used in file explorer-like widgets, which the collapsed attachment bar is not. In fact, there's no reason to ever select the single attachment in the collapsed bar, since you wouldn't be able to do anything with it even if it were selected. Thus, we just make the single click action be "open". The current way is actually more consistent with other related UI, e.g. the message header.

I suppose it's technically possible to ignore double-clicks so that people can double-click to their heart's content without opening spurious windows, but I don't think we should just do nothing on single-click.

Blake, ideas on this?
Whiteboard: wontfix?
(Reporter)

Comment 2

6 years ago
To recap:

- with a single attachment, the bar indicates '1 attachment:' followed by the name followed by the size
- with multiple attachments, the bar indicates 'x attachments' followed by the size
- a single click expands/collapses the attachments bar
- a single click on the attachment count caption 'x attachment(s)' does nothing
- a single click on the size caption 'xxx KB' does nothing
- a single click *BETWEEN* the attachment count caption and the file name or size caption expands the bar

here's the 'anomaly' when there is a single attachment with the name on the bar:
- the name of the file is not indicated as 'clickable' (highlight, underline, mouse pointer, etc.)
- a single click on the name of the file opens the file
- when the bar is open, you need a double click to open the file from the list of attachments but only a single click if using the name on the bar

Comment 3

6 years ago
I've been fairly surprised by this too, and keep double-clicking which leads to opening multiple instances of the document :(

I don't know if this should be compared to other parts of the ui, as this part actually brings up another application, which is not the case elsewhere.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

6 years ago
(In reply to DutchGemini from comment #2)
> here's the 'anomaly' when there is a single attachment with the name on the
> bar:
> - the name of the file is not indicated as 'clickable' (highlight,
> underline, mouse pointer, etc.)

Yes it is. Mousing over the filename highlights it just like when you mouse over an email address.
(Reporter)

Comment 5

6 years ago
You are right. It was not doing so because I'm using the "Office Black 1.6.6" skin, with the "Default 7.0.1" skin it indeed highlights. Will need to contact the maker of it.
Keywords: ux-consistency
(Assignee)

Comment 6

5 years ago
Created attachment 651082 [details] [diff] [review]
Ignore double-clicks on the attachment bar

Ok, this patch ignores double-clicks when you click on the attachment name in the attachment bar. That way, people can double-click or single-click and get the same result.
Assignee: nobody → squibblyflabbetydoo
Status: NEW → ASSIGNED
Attachment #651082 - Flags: ui-review?(bwinton)
Attachment #651082 - Flags: review?(bwinton)
(Assignee)

Updated

5 years ago
Component: Folder and Message Lists → Message Reader UI
Comment on attachment 651082 [details] [diff] [review]
Ignore double-clicks on the attachment bar

>+++ b/mail/base/content/msgHdrViewOverlay.js
>@@ -2423,16 +2423,33 @@ function addAttachmentToPopup(popup, att
> /**
>+ * Open an attachment from the attachment bar.
>+ *
>+ * @param event the event that triggered this action
>+ */
>+function OpenAttachmentFromBar(event)
>+{
>+  if (event.button == 0) {
>+    // Only open on the first click; ignore double-clicks so that the user
>+    // doesn't end up with the attachment opened multiple times.
>+    if (event.detail == 1)
>+      TryHandleAllAttachments('open');
>+    RestoreFocusAfterHdrButton();
>+    event.stopPropagation();
>+  }
>+}

That seems better.  ui-r=me.
And the code looks good, too.  r=me.

Thanks,
Blake.
Attachment #651082 - Flags: ui-review?(bwinton)
Attachment #651082 - Flags: ui-review+
Attachment #651082 - Flags: review?(bwinton)
Attachment #651082 - Flags: review+
(Assignee)

Comment 8

5 years ago
Checked in: http://hg.mozilla.org/comm-central/rev/e50828052087
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: wontfix?
Target Milestone: --- → Thunderbird 17.0
(Assignee)

Updated

5 years ago
Duplicate of this bug: 812126
You need to log in before you can comment on or make changes to this bug.