Need memory reporters for Thunderbird

RESOLVED DUPLICATE of bug 480843

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 480843
6 years ago
6 years ago

People

(Reporter: Away for a while, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
I was curious to know why my Thunderbird is using 2gigs of memory today, so I opened about:memory in it and here's what I saw:

Main Process

Explicit Allocations
2,471.95 MB (100.0%) -- explicit
├──2,231.38 MB (90.27%) -- heap-unclassified
├────167.20 MB (06.76%) -- js
│    ├───76.18 MB (03.08%) -- gc-heap-chunk-dirty-unused
│    ├───76.12 MB (03.08%) -- compartment([System Principal], 0x118891000)
│    │   ├──53.05 MB (02.15%) -- gc-heap
│    │   │  ├──36.24 MB (01.47%) -- objects
│    │   │  └──16.81 MB (00.68%) -- (8 omitted)
│    │   └──23.07 MB (00.93%) -- (10 omitted)
│    └───14.90 MB (00.60%) -- (7 omitted)
├─────67.02 MB (02.71%) -- storage
│     └──67.02 MB (02.71%) -- sqlite
│        ├──64.59 MB (02.61%) -- global-messages-db.sqlite
│        │  ├──64.49 MB (02.61%) -- cache-used
│        │  └───0.10 MB (00.00%) -- (2 omitted)
│        └───2.43 MB (00.10%) -- (9 omitted)
└──────6.35 MB (00.26%) -- (7 omitted)

Other Measurements
    1.29 MB -- gfx-surface-image
2,325.81 MB -- heap-allocated
2,364.77 MB -- heap-committed
      1.64% -- heap-committed-unallocated-fraction
    2.29 MB -- heap-dirty
   75.18 MB -- heap-unallocated
          2 -- js-compartments-system
          6 -- js-compartments-user
  134.00 MB -- js-gc-heap
    5.00 MB -- js-gc-heap-arena-unused
    0.00 MB -- js-gc-heap-chunk-clean-unused
   76.18 MB -- js-gc-heap-chunk-dirty-unused
     60.58% -- js-gc-heap-unused-fraction
    103,920 -- page-faults-hard
  2,648,793 -- page-faults-soft
2,099.89 MB -- resident
5,960.39 MB -- vsize



This means that Thunderbird desperately needs some memory reporter love.  CCing some MemShrink folks who might be able to help here.  In particular, Nick has a Dark Matter detection tools which can help you focus on adding more important memory reporters first.

Comment 1

6 years ago
requested long ago :)
bug 480841, bug 480843

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 480843
You need to log in before you can comment on or make changes to this bug.