Closed Bug 697183 Opened 8 years ago Closed 8 years ago

Fennec crashes on rotation

Categories

(Firefox for Android :: General, defect, critical)

ARM
Linux
defect
Not set
critical

Tracking

()

VERIFIED FIXED

People

(Reporter: kats, Assigned: kats)

References

Details

Attachments

(1 file)

Load a page, then rotate the device. Fennec crashes with the following stack:

E/GeckoApp(19523): top level exception
E/GeckoApp(19523): java.lang.RuntimeException: Unable to start activity ComponentInfo{org.mozilla.fennec_kats/org.mozilla.fennec_kats.App}: java.lang.NullPointerException
E/GeckoApp(19523): 	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:1751)
E/GeckoApp(19523): 	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:1767)
E/GeckoApp(19523): 	at android.app.ActivityThread.handleRelaunchActivity(ActivityThread.java:3117)
E/GeckoApp(19523): 	at android.app.ActivityThread.access$1600(ActivityThread.java:122)
E/GeckoApp(19523): 	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1009)
E/GeckoApp(19523): 	at android.os.Handler.dispatchMessage(Handler.java:99)
E/GeckoApp(19523): 	at android.os.Looper.loop(Looper.java:132)
E/GeckoApp(19523): 	at org.mozilla.gecko.GeckoApp$18.run(GeckoApp.java:970)
E/GeckoApp(19523): 	at android.os.Handler.handleCallback(Handler.java:587)
E/GeckoApp(19523): 	at android.os.Handler.dispatchMessage(Handler.java:92)
E/GeckoApp(19523): 	at android.os.Looper.loop(Looper.java:132)
E/GeckoApp(19523): 	at android.app.ActivityThread.main(ActivityThread.java:4028)
E/GeckoApp(19523): 	at java.lang.reflect.Method.invokeNative(Native Method)
E/GeckoApp(19523): 	at java.lang.reflect.Method.invoke(Method.java:491)
E/GeckoApp(19523): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:844)
E/GeckoApp(19523): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:602)
E/GeckoApp(19523): 	at dalvik.system.NativeStart.main(Native Method)
E/GeckoApp(19523): Caused by: java.lang.NullPointerException
E/GeckoApp(19523): 	at org.mozilla.gecko.GeckoApp.onCreate(GeckoApp.java:942)                               <--- this is the line mBrowserToolbar.setTitle(tab.getTitle())
E/GeckoApp(19523): 	at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1048)
E/GeckoApp(19523): 	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:1715)
E/GeckoApp(19523): 	... 16 more


Patch forthcoming
Attached patch Fix NPESplinter Review
Attachment #569424 - Flags: review?(lucasr.at.mozilla)
Attachment #569424 - Flags: review?(lucasr.at.mozilla) → review+
Pushed: http://hg.mozilla.org/projects/birch/rev/0668a17050a3
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Duplicate of this bug: 697435
20111026100509
http://hg.mozilla.org/projects/birch/rev/0668a17050a3
Status: RESOLVED → VERIFIED
Severity: normal → critical
OS: Mac OS X → Linux
Hardware: x86 → ARM
You need to log in before you can comment on or make changes to this bug.