password dialog missing button, has reversed order buttons

VERIFIED FIXED in M14

Status

Core Graveyard
Tracking
P2
normal
VERIFIED FIXED
19 years ago
a year ago

People

(Reporter: cpratt, Assigned: davidm)

Tracking

Trunk
All
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
build id: 199905[22,23,24]08 builds (mac os, win32, linux)
platforms: all

to reproduce: bring up the password dialog box. it only has two buttons - ok and
cancel - and they're in the wrong order.

expected result: three buttons. "OK" "Clear" "Cancel" (in that order, left to
right). OK should be the default button.

additionally, where it currently says "User", it should say "User ID".

oh, and if it's possible, "User ID" and "Password" should be right- and not
left-justified.

Comment 1

19 years ago
reassign to don for proper engineer to fix it later. cc german so he can provide
dialog design/templetes (if any) to the team.

Comment 2

19 years ago
reassign to don for proper engineer to fix it later. cc german so he can provide
dialog design/templetes (if any) to the team.

Updated

19 years ago
Assignee: don → davidm
Component: UE/UI → other
Priority: P3 → P2
Target Milestone: M7
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M7 → M10
(Assignee)

Comment 3

19 years ago
The buttons are in the right order. Eventually they will adapt to their platform.
May not impliment the clear button  since it is added work. Moving off to m10
when I have UI cleanup on the schedule.
(Assignee)

Updated

19 years ago
Target Milestone: M10 → M14
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

18 years ago
Marking fixed. Button order now adapts to the platform and I am using the dialog
template that german provided. It can be changed later in life. I am not
implementing a clear button. Default button behavior has not been implemented
but bugs have been filed about it.

Comment 5

18 years ago
Setting QA Contact.
Status: RESOLVED → VERIFIED
QA Contact: jrgm
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.