Closed Bug 697320 Opened 11 years ago Closed 8 years ago

opez.com - Firefox 7.0.1 renders the word "financial" as "nancial" in several places due to missing ligature glyph (bad font)

Categories

(Web Compatibility :: Desktop, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: bugzilla.mozilla.org, Unassigned)

References

()

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

Go to the website http://opez.com/bob using firefox 7.0.1 on Mac (Mac OS X 10.6.8)


Actual results:

See the word FINANCIAL rendered as NANCIAL on several places on that web page.  The HTML seems normal.


Expected results:

The word FINANCIAL should be rendered properly.
I see the same with a recent nightly (10.0a1 (2011-10-22)). There is something wrong with the font used - font-family: NimbusSanNov-Med; (web font)
Component: General → Layout: Text
Product: Firefox → Core
QA Contact: general → layout.fonts-and-text
Version: 7 Branch → unspecified
It's a broken font; the author should complain to his font provider (myfonts.com).

The problem is that in this font many glyphs - basically everything except the Latin-1 set, I think - have been replaced with blanks, but the OpenType tables that implement things like the "fi" ligature are still present. As Firefox supports OpenType ligatures, it (correctly) replaces the sequence <f, i> with the <fi> glyph - which is blank.

The attached screenshot shows the glyph palette of the font, with many glyphs - including the f-ligatures - being blank.
Moving to Tech Evangelism, as this is not a Gecko/Firefox bug; it needs to be fixed by the font provider.

I've written to a contact at myfonts.com to point out the problem.
Assignee: nobody → english-us
Component: Layout: Text → English US
Product: Core → Tech Evangelism
QA Contact: layout.fonts-and-text → english-us
Regression window:
Works:
http://hg.mozilla.org/mozilla-central/rev/69c86f3acc5a
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2a1pre) Gecko/20090224 Minefield/3.2a1pre ID:20090224033722
Fails:
http://hg.mozilla.org/mozilla-central/rev/8eba35e62d92
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2a1pre) Gecko/20090225 Minefield/3.2a1pre ID:20090225033705
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=69c86f3acc5a&tochange=8eba35e62d92

Triggered by
d08d06bdd4c9	John Daggett — Bug 475164 - accept fonts that have null name records. r=vlad

Why Google Chrome display correctly? and Firefox not?
Blocks: 475164
OS: Mac OS X → All
(In reply to Alice0775 White from comment #4)
 
> Why Google Chrome display correctly? and Firefox not?

Because ligatures are not turned on by default in WebKit. If you add 'text-rendering: optimizeLegibility;' to the root element through the WebKit inspector, you'll see the same issue.

(note that on Gecko 1.9.2, OS X 10.6.8, it does display the 'fi' 'correctly', but it falls back on the default font)
(In reply to philippe from comment #5)
> (In reply to Alice0775 White from comment #4)
>  
> > Why Google Chrome display correctly? and Firefox not?
> 
> Because ligatures are not turned on by default in WebKit. If you add
> 'text-rendering: optimizeLegibility;' to the root element through the WebKit
> inspector, you'll see the same issue.
> 
Thanks

> (note that on Gecko 1.9.2, OS X 10.6.8, it does display the 'fi'
> 'correctly', but it falls back on the default font)

Why Firefox3.6.23  does not fall back on window?
Why Firefox7.0 and later version do not  fall back ?
My contact at MyFonts.com has acknowledged the problem, and says they're working on an improved toolset.

Meanwhile, there's no need for further technical investigation here; it's clear that this is a font error, not a Firefox bug.

The site author should either change fonts, or deploy a corrected version - the simplest fix would be to strip the OpenType layout tables from the font, or to avoid "subsetting" by blanking out many glyphs.

(Another possible workaround might be to add "-moz-font-feature-settings: 'liga=0'" to the site's CSS, so as to explicitly turn off default ligatures.)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Testcase that shows the problem in Firefox/Safari/Chrome:
http://people.mozilla.org/~jdaggett/tests/bug697320.html

Includes text-rendering to enable ligatures in Safari/Chrome.

Sent a message to the page owner.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → INVALID
TE bugs shouldn't generally be resolved INVALID, especially when there's something the site is doing wrong (see comment 7).
Status: RESOLVED → REOPENED
Hardware: x86 → All
Resolution: INVALID → ---
Summary: Firefox 7.0.1 renders the word financial as nancial in several places on a web page → opez.com - Firefox 7.0.1 renders the word "financial" as "nancial" in several places due to missing ligature glyph (bad font)
Duplicate of this bug: 711896
Blocks: 718479
Hmm no luck this morning.

> Under Maintenance
> Hey there — we apologize, but Opez is currently under maintenance. 
> If you have any pressing issues, please feel free to reach out to us: contact@opez.com.

Let's see
The site was already on Maintenance on March 8, 2013.
http://web.archive.org/web/20130308023028/http://opez.com/bob

Let's close it as INVALID.
Assignee: english-us → nobody
Status: REOPENED → RESOLVED
Closed: 11 years ago8 years ago
Component: English US → Desktop
Resolution: --- → INVALID
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.