link to comment in emails looks like it is part of the comment

RESOLVED FIXED in Bugzilla 4.4

Status

()

RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: glob, Assigned: dkl)

Tracking

Bugzilla 4.4
Bug Flags:
approval +

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

7 years ago
bug 365709 added a link to the comment to all emails:

> Do not reply to this email.  You can add comments to this bug at
> https://bugzilla.mozilla.org/show_bug.cgi?id=697365
> 
> --- Comment #2 from Chris Jones [:cjones] [:warhammer] <jones.chris.g@gmail.com> 2011-10-26 00:11:25 PDT ---
> https://bugzilla.mozilla.org/show_bug.cgi?id=697365#c2
> \o/ heroic!

the link looks like it's part of the comment.

i suggest:

> Do not reply to this email.  You can add comments to this bug at
> https://bugzilla.mozilla.org/show_bug.cgi?id=697365#c2
> 
> --- Comment #2 from Chris Jones [:cjones] [:warhammer] <jones.chris.g@gmail.com> 2011-10-26 00:11:25 PDT ---
> \o/ heroic!
(Reporter)

Comment 1

7 years ago
hrm, that won't work if there's more than one comment, how about:

> Do not reply to this email.  You can add comments to this bug at
> https://bugzilla.mozilla.org/show_bug.cgi?id=697365
> 
> https://bugzilla.mozilla.org/show_bug.cgi?id=697365#c2
> --- Comment #2 from Chris Jones [:cjones] [:warhammer] <jones.chris.g@gmail.com> 2011-10-26 00:11:25 PDT ---
> \o/ heroic!

or

> Do not reply to this email.  You can add comments to this bug at
> https://bugzilla.mozilla.org/show_bug.cgi?id=697365
> 
> --- Comment #2 from Chris Jones [:cjones] [:warhammer] <jones.chris.g@gmail.com> 2011-10-26 00:11:25 PDT ---
> \o/ heroic!
> --- https://bugzilla.mozilla.org/show_bug.cgi?id=697365#c2
(Assignee)

Comment 2

7 years ago
(In reply to Byron Jones ‹:glob› from comment #1)
> > --- Comment #2 from Chris Jones [:cjones] [:warhammer] <jones.chris.g@gmail.com> 2011-10-26 00:11:25 PDT ---
> > \o/ heroic!
> > --- https://bugzilla.mozilla.org/show_bug.cgi?id=697365#c2

I like that one but I would take it further and do:

--- Comment #2 from Chris Jones [:cjones] [:warhammer] <jones.chris.g@gmail.com> 2011-10-26 00:11:25 PDT ---
\o/ heroic!

 ---> https://bugzilla.mozilla.org/show_bug.cgi?id=697365#c2

We do this already for attachments/reviews in bug mails. I am indifferent about having a new line between the comment text and the link line, but it might make it less confusing to have it there so the link looks less part of the comment.

dkl
Assignee: email-notifications → dkl
Status: NEW → ASSIGNED
(Assignee)

Comment 3

7 years ago
Created attachment 569712 [details] [diff] [review]
Patch to move comment link below comment (v1)

Here is a patch showing the comment link below the comment text denoted with 
'-->'.

Example:

--- Comment #4 from admin <admin@mozilla.com> ---
Adding another comment.

 --> http://fedora/697371/show_bug.cgi?id=1#c4

dkl
Attachment #569712 - Flags: review?(glob)
(Reporter)

Comment 4

7 years ago
Comment on attachment 569712 [details] [diff] [review]
Patch to move comment link below comment (v1)

r=glob excellent :)
Attachment #569712 - Flags: review?(glob) → review+
(Reporter)

Updated

7 years ago
Flags: approval?

Comment 5

7 years ago
I would prefer to have the link at the top of the email. Most of the time, I stop reading long comments in emails and watch the bug in my web browser directly. This would also be more consistent with the link to the bug, which is also at the top.
Flags: approval?

Updated

7 years ago
Target Milestone: --- → Bugzilla 5.0
(Assignee)

Comment 6

7 years ago
(In reply to Frédéric Buclin from comment #5)
> I would prefer to have the link at the top of the email. Most of the time, I
> stop reading long comments in emails and watch the bug in my web browser
> directly. This would also be more consistent with the link to the bug, which
> is also at the top.

Personally I think it is best to keep them with the comment. Especially in the case there is more than one comment in the single bug mail. In the template the comments are printed in a loop as well so even the template is implemented to work with one or more templates.

Also I would think the biggest need for the comment link is if someone wants to reply to a comment from the email so they have already read the comment and the link will be right there conveniently located. 

As for above or below the comment text itself, I am not particular. Byron and I felt it could possibly be confused as part of the comment text and having underneath with the --> in front may lesson the confusion. Although having it at the top of the comment may help with your use case where you do not want to read the full comment.

dkl
(Reporter)

Comment 7

7 years ago
as there's a bmo push scheduled for today, i've committed the patch as-is to bmo:

Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bmo/4.0/
modified template/en/default/email/newchangedmail.txt.tmpl
Committed revision 7919.


for bugzilla/trunk it problem is different because the initial url to the bug was removed when bugmail was refactored.

a better fix would be to resurrect the url to the start of the email, appending the comment anchor if there are comments on the bug.  we only need to link to the first comment added, but we'd have to take care to factor in the user's comment sorting preference to ensure we link to the right "first" comment.

Comment 8

7 years ago
This change makes things slightly better than after bug 365709 landed, but it still looks like someone added a URL in the comment itself.

Would it be possible to make the change suggested in comment 7, since it's affecting quite a few people, eg:

smaug: I hate the new bugmail format
mounir: smaug: you mean the --> url at the end? so annoying
smaug: yes
hsivonen: mounir: it looks like part of the comment
smaug: I all the time think that someone added a link to the comment
mounir: hsivonen, smaug: it was worse before when the comment was at the beginning
mounir: I wonder why it's not below the bug comment

Thanks :-)
(Assignee)

Comment 9

7 years ago
Here is what I propose:. We move the comment link(s) to the top of the email below the main bug link if one or more comments exist in the email. We create footnote style numbering to link to the comment below in the email body.

--- Sample ---

Do not reply to this email.  You can add comments to this bug at
https://bugzilla.mozilla.org/show_bug.cgi?id=697371

Ed Morley [:edmorley] <bmo@edmorley.co.uk> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |bmo@edmorley.co.uk

Comment Links:
[8] https://bugzilla.mozilla.org/show_bug.cgi?id=697371#c8

--- Comment #8 [1] from Ed Morley [:edmorley] <bmo@edmorley.co.uk> 2011-11-01 05:12:36 PDT ---
This change makes things slightly better than after bug 365709 landed, but it
still looks like someone added a URL in the comment itself.

Would it be possible to make the change suggested in comment 7, since it's
affecting quite a few people, eg:

smaug: I hate the new bugmail format
mounir: smaug: you mean the --> url at the end? so annoying
smaug: yes
hsivonen: mounir: it looks like part of the comment
smaug: I all the time think that someone added a link to the comment
mounir: hsivonen, smaug: it was worse before when the comment was at the
beginning
mounir: I wonder why it's not below the bug comment

Thanks 

-- Configure bugmail: https://bugzilla.mozilla.org/userprefs.cgi?tab=email ------- You are receiving this mail because: ------- You are on the CC list for the bug. You are the assignee for the bug. 

--- End Sample ---

Thoughts?
dkl
(Assignee)

Comment 10

7 years ago
(In reply to David Lawrence [:dkl] from comment #9)

> --- Comment #8 [1] from Ed Morley [:edmorley] <bmo@edmorley.co.uk>
> 2011-11-01 05:12:36 PDT ---

Change that to:

--- Comment #8 from Ed Morley [:edmorley] <bmo@edmorley.co.uk> 2011-11-01 05:12:36 PDT ---

Also my earlier comment was confusing that in my sample I decided to put the list of comment links below the standard changes list instead at the top below the main bug link. I think this is better to keep "types" of changes grouped together.

dkl
(Reporter)

Comment 11

7 years ago
i think that's adding too much noise to the email.

it'll look worse when there's just a comment, without the change list to break it up:

> Do not reply to this email.  You can add comments to this bug at
> https://bugzilla.mozilla.org/show_bug.cgi?id=697371
> 
> Comment Links:
> [10] https://bugzilla.mozilla.org/show_bug.cgi?id=697371#c10
> 
> --- Comment #10 from David Lawrence [:dkl] <dkl@mozilla.com> 2011-11-01 07:38:18 PDT ---
> this is a comment

instead i think this should look like:

> Do not reply to this email.  You can add comments to this bug at
> https://bugzilla.mozilla.org/show_bug.cgi?id=697371#c10
> 
> --- Comment #10 from David Lawrence [:dkl] <dkl@mozilla.com> 2011-11-01 07:38:18 PDT ---
> this is a comment

the vast majority of bugmail sent has a single comment in it, let's focus on making that look good.
(Assignee)

Comment 12

7 years ago
(In reply to Byron Jones ‹:glob› from comment #11)
> > Do not reply to this email.  You can add comments to this bug at
> > https://bugzilla.mozilla.org/show_bug.cgi?id=697371#c10
> > 
> > --- Comment #10 from David Lawrence [:dkl] <dkl@mozilla.com> 2011-11-01 07:38:18 PDT ---
> > this is a comment
> 
> the vast majority of bugmail sent has a single comment in it, let's focus on
> making that look good.

That looks fine when there is just a comment in the email and no other changes. But what of the usage case where there are a lot of attribute changes and the user wants to go to the bug and not have to scroll back up from the last comment to make another attribute change of their own? If the bug has a lot of comments (which some do) then it might be annoying. 

Anyway, leave it to me to not read the text that is already there in the email. 

> Do not reply to this email.  You can add comments to this bug at

So I agree that this should have been a link to the posted comment all along and
not the full bug. If a user links to the comment, they can then 1) reply to the same comment, or 2) post a new comment in the comment textarea that normally is near the last comment anyway. 

Strange thing about that do not reply part. In the template it is not added to the email if the user has full product chooser selected in their preferences. How are they related anyway?
I would think that the sentence can always be present.

> [% UNLESS to_user.settings.product_chooser.value == 'full_product_chooser' %]
> Do not reply to this email.  You can add comments to this [% terms.bug %] at
> [% END %]

I am fine with making globs proposed change to allow us to 1) keep it simple and uncluttered, and 2) move on from this issue :)

dkl
(Assignee)

Comment 13

7 years ago
Created attachment 571227 [details] [diff] [review]
Patch to add comment id to bug link in bugmail (v1)

New patch that adds the comment id to the bug link instead of below the comment.
Let me know what you think.
dkl
Attachment #571227 - Flags: review?(glob)
(Reporter)

Comment 14

7 years ago
Comment on attachment 571227 [details] [diff] [review]
Patch to add comment id to bug link in bugmail (v1)

the patch appears to be for bugzilla 4.x, not trunk.
Attachment #571227 - Flags: review?(glob) → review-
(Assignee)

Comment 15

7 years ago
Created attachment 571229 [details] [diff] [review]
Patch to add comment id to bug link in text bugmail (v2)

New patch for trunk only. Will attach sep. patch for bmo/4.0.

dkl
Attachment #571227 - Attachment is obsolete: true
Attachment #571229 - Flags: review?(glob)
(Reporter)

Updated

7 years ago
Attachment #569712 - Attachment is obsolete: true
(Assignee)

Comment 16

7 years ago
Created attachment 571234 [details] [diff] [review]
Patch to add comment id to bug link in text bugmail (BMO) (v2)

Patch for BMO 4.0

dkl
Attachment #571234 - Flags: review?(glob)
(Reporter)

Comment 17

7 years ago
Comment on attachment 571234 [details] [diff] [review]
Patch to add comment id to bug link in text bugmail (BMO) (v2)

>-Do not reply to this email.  You can add comments to this [% terms.bug %] at
>+Do not reply to this email. You can add comments to this [% terms.bug %] at

there's no need for this change.

everything else is good; r=glob with the above change removed.
(Reporter)

Comment 18

7 years ago
Comment on attachment 571229 [details] [diff] [review]
Patch to add comment id to bug link in text bugmail (v2)

r=glob
Attachment #571229 - Flags: review?(glob) → review+
(Reporter)

Updated

7 years ago
Flags: approval?
(Reporter)

Updated

7 years ago
Duplicate of this bug: 699045

Updated

7 years ago
Flags: approval? → approval+
(Assignee)

Comment 20

7 years ago
Committing to: bzr+ssh://dlawrence%40mozilla.com@bzr.mozilla.org/bugzilla/trunkmodified template/en/default/email/bugmail.txt.tmpl
Committed revision 8000.

dkl
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Attachment #571234 - Flags: review?(glob)
You need to log in before you can comment on or make changes to this bug.